diff options
author | Ross Burton <ross.burton@arm.com> | 2024-06-06 17:20:15 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2024-06-07 23:21:42 +0100 |
commit | 46c0ed2fad5b3a862512f106758b11692a72d47b (patch) | |
tree | 20bc6f9fbce91fc197bcfce732de4db3bf433319 /meta/recipes-devtools/python/python3-cython_3.0.10.bb | |
parent | 4928c4806f4ed4d277c0cefe03c3169df551b018 (diff) | |
download | poky-46c0ed2fad5b3a862512f106758b11692a72d47b.tar.gz |
python3-cython: remove redundant .inc file
There is no python-cython recipe in core, so merge the .bb and .inc.
(From OE-Core rev: 6c2cf318289cbd8c2732f8f7ddaa6750ab0f0276)
Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-cython_3.0.10.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3-cython_3.0.10.bb | 47 |
1 files changed, 42 insertions, 5 deletions
diff --git a/meta/recipes-devtools/python/python3-cython_3.0.10.bb b/meta/recipes-devtools/python/python3-cython_3.0.10.bb index 07638d7ad7..754543e711 100644 --- a/meta/recipes-devtools/python/python3-cython_3.0.10.bb +++ b/meta/recipes-devtools/python/python3-cython_3.0.10.bb | |||
@@ -1,9 +1,17 @@ | |||
1 | inherit setuptools3 | 1 | SUMMARY = "The Cython language" |
2 | require python-cython.inc | 2 | HOMEPAGE = "https://pypi.org/project/Cython/" |
3 | DESCRIPTION = "Cython is a language specially designed for writing Python extension modules. \ | ||
4 | It's designed to bridge the gap between the nice, high-level, easy-to-use world of Python \ | ||
5 | and the messy, low-level world of C." | ||
6 | SECTION = "devel/python" | ||
7 | LICENSE = "Apache-2.0" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=61c3ee8961575861fa86c7e62bc9f69c" | ||
9 | PYPI_PACKAGE = "Cython" | ||
3 | 10 | ||
4 | RDEPENDS:${PN} += "\ | 11 | SRC_URI[sha256sum] = "dcc96739331fb854dcf503f94607576cfe8488066c61ca50dfd55836f132de99" |
5 | python3-setuptools \ | 12 | UPSTREAM_CHECK_REGEX = "Cython-(?P<pver>.*)\.tar" |
6 | " | 13 | |
14 | inherit pypi setuptools3 | ||
7 | 15 | ||
8 | # running build_ext a second time during install fails, because Python | 16 | # running build_ext a second time during install fails, because Python |
9 | # would then attempt to import cythonized modules built for the target | 17 | # would then attempt to import cythonized modules built for the target |
@@ -11,6 +19,14 @@ RDEPENDS:${PN} += "\ | |||
11 | SETUPTOOLS_INSTALL_ARGS += "--skip-build" | 19 | SETUPTOOLS_INSTALL_ARGS += "--skip-build" |
12 | 20 | ||
13 | do_install:append() { | 21 | do_install:append() { |
22 | # Make sure we use /usr/bin/env python3 | ||
23 | for PYTHSCRIPT in `grep -rIl '^#!.*python' ${D}`; do | ||
24 | sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT | ||
25 | done | ||
26 | |||
27 | # remove build paths from generated sources | ||
28 | sed -i -e 's|${WORKDIR}||' ${S}/Cython/*.c ${S}/Cython/Compiler/*.c ${S}/Cython/Plex/*.c | ||
29 | |||
14 | # rename scripts that would conflict with the Python 2 build of Cython | 30 | # rename scripts that would conflict with the Python 2 build of Cython |
15 | mv ${D}${bindir}/cython ${D}${bindir}/cython3 | 31 | mv ${D}${bindir}/cython ${D}${bindir}/cython3 |
16 | mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3 | 32 | mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3 |
@@ -35,3 +51,24 @@ cython_fix_sources () { | |||
35 | done | 51 | done |
36 | } | 52 | } |
37 | 53 | ||
54 | RDEPENDS:${PN}:class-target += "\ | ||
55 | python3-misc \ | ||
56 | python3-netserver \ | ||
57 | python3-pkgutil \ | ||
58 | python3-pyparsing \ | ||
59 | python3-setuptools \ | ||
60 | python3-shell \ | ||
61 | python3-xml \ | ||
62 | " | ||
63 | |||
64 | RDEPENDS:${PN}:class-nativesdk += "\ | ||
65 | nativesdk-python3-misc \ | ||
66 | nativesdk-python3-netserver \ | ||
67 | nativesdk-python3-pkgutil \ | ||
68 | nativesdk-python3-pyparsing \ | ||
69 | nativesdk-python3-setuptools \ | ||
70 | nativesdk-python3-shell \ | ||
71 | nativesdk-python3-xml \ | ||
72 | " | ||
73 | |||
74 | BBCLASSEXTEND = "native nativesdk" | ||