summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-cryptography-vectors_42.0.8.bb
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-06-11 10:52:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-06-12 16:08:31 +0100
commit8eae3a9ee929ab18519037fd4a85e580d7c7a1ec (patch)
tree6f4496b9b02d67cdecb2b8d683bb44d819b5940b /meta/recipes-devtools/python/python3-cryptography-vectors_42.0.8.bb
parent055867b32706cae7671e37fd43e67d403fc3269f (diff)
downloadpoky-8eae3a9ee929ab18519037fd4a85e580d7c7a1ec.tar.gz
python3-cryptography: upgrade 42.0.7 -> 42.0.8
* Refresh 0001-pyproject.toml-remove-benchmark-disable-option.patch * Also upgrade python3-cryptography-vectors 42.0.8 - 2024-06-04 * Updated Windows, macOS, and Linux wheels to be compiled with OpenSSL 3.2.2. https://cryptography.io/en/latest/changelog/#v42-0-8 https://github.com/pyca/cryptography/compare/42.0.7...42.0.8 (From OE-Core rev: 90c171a599b9800f2cfa5c8764f19358d7b4590c) Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-cryptography-vectors_42.0.8.bb')
-rw-r--r--meta/recipes-devtools/python/python3-cryptography-vectors_42.0.8.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-cryptography-vectors_42.0.8.bb b/meta/recipes-devtools/python/python3-cryptography-vectors_42.0.8.bb
new file mode 100644
index 0000000000..1256e75c47
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-cryptography-vectors_42.0.8.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Test vectors for the cryptography package."
2HOMEPAGE = "https://cryptography.io/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0 | BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \
6 file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \
7 file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b"
8
9# NOTE: Make sure to keep this recipe at the same version as python3-cryptography
10# Upgrade both recipes at the same time
11
12SRC_URI[sha256sum] = "df5657367bc0a90c374309cb261009a2c53cae91a458781339a0f724f819a46a"
13
14PYPI_PACKAGE = "cryptography_vectors"
15
16inherit pypi python_setuptools_build_meta
17
18DEPENDS += " \
19 python3-cryptography \
20"
21
22do_install:append () {
23 # Remove the sha256 checksum lines for pycache files
24 sed ${D}${PYTHON_SITEPACKAGES_DIR}/cryptography_vectors-${PV}.dist-info/RECORD -e '/__pycache__/d' -i
25}
26
27BBCLASSEXTEND = "native nativesdk"
28
29UPSTREAM_CHECK_REGEX = ""
30
31RECIPE_NO_UPDATE_REASON = "Must be updated in sync with python3-cryptography."