summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-cryptography-vectors_41.0.7.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2023-11-28 20:11:38 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-12-02 17:18:57 +0000
commita5ee86fd998bb3eb3211933ac87daf584b009152 (patch)
treea62b303af623097822db6ea0ae375431917cde62 /meta/recipes-devtools/python/python3-cryptography-vectors_41.0.7.bb
parent076862d68e2dcda7a16a393fdcbd540a552cdbff (diff)
downloadpoky-a5ee86fd998bb3eb3211933ac87daf584b009152.tar.gz
python3-cryptography{-vectors}: 41.0.5 -> 41.0.7
https://github.com/pyca/cryptography/compare/41.0.5...41.0.7 https://cryptography.io/en/latest/changelog/#v41-0-7 https://cryptography.io/en/latest/changelog/#v41-0-6 41.0.7 - 2023-11-27 Fixed compilation when using LibreSSL 3.8.2. 41.0.6 - 2023-11-27 Fixed a null-pointer-dereference and segfault that could occur when loading certificates from a PKCS#7 bundle. Credit to pkuzco for reporting the issue. CVE: CVE-2023-49083 (From OE-Core rev: 25fba6dd44f64e1e476c2e537d4a20cdbdc7ed25) Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-cryptography-vectors_41.0.7.bb')
-rw-r--r--meta/recipes-devtools/python/python3-cryptography-vectors_41.0.7.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-cryptography-vectors_41.0.7.bb b/meta/recipes-devtools/python/python3-cryptography-vectors_41.0.7.bb
new file mode 100644
index 0000000000..eda492d312
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-cryptography-vectors_41.0.7.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Test vectors for the cryptography package."
2HOMEPAGE = "https://cryptography.io/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0 | BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \
6 file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \
7 file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b"
8
9# NOTE: Make sure to keep this recipe at the same version as python3-cryptography
10# Upgrade both recipes at the same time
11
12SRC_URI[sha256sum] = "7b36f976b6e58cc1801310e1c93c584c6539d371da7f8538edd8fc463dc80d5b"
13
14PYPI_PACKAGE = "cryptography_vectors"
15
16inherit pypi python_setuptools_build_meta
17
18DEPENDS += " \
19 ${PYTHON_PN}-cryptography \
20"
21
22do_install:append () {
23 # Remove the sha256 checksum lines for pycache files
24 sed ${D}${PYTHON_SITEPACKAGES_DIR}/cryptography_vectors-${PV}.dist-info/RECORD -e '/__pycache__/d' -i
25}
26
27BBCLASSEXTEND = "native nativesdk"
28
29UPSTREAM_CHECK_REGEX = ""
30
31RECIPE_NO_UPDATE_REASON = "Must be updated in sync with python3-cryptography."