summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-cryptography-vectors_41.0.3.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2023-08-03 12:48:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-08-10 09:18:53 +0100
commit9af6495ee4bf1fb8cc17a0e221d4a58f5f70aa3b (patch)
treec80e82b5c964548ddcb3463e3516551750788593 /meta/recipes-devtools/python/python3-cryptography-vectors_41.0.3.bb
parent515532b5c3586967abad04fcda9f25ec8d4ae065 (diff)
downloadpoky-9af6495ee4bf1fb8cc17a0e221d4a58f5f70aa3b.tar.gz
python3-cryptography{-vectors}: upgrade -> 41.0.3
https://cryptography.io/en/latest/changelog/#v41-0-3 * Fixed performance regression loading DH public keys. * Fixed a memory leak when using ChaCha20Poly1305. * Updated Windows, macOS, and Linux wheels to be compiled with OpenSSL 3.1.2. (From OE-Core rev: 51f540260e858e77031c569721eb01dba24365c9) Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-cryptography-vectors_41.0.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-cryptography-vectors_41.0.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-cryptography-vectors_41.0.3.bb b/meta/recipes-devtools/python/python3-cryptography-vectors_41.0.3.bb
new file mode 100644
index 0000000000..1b499e0299
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-cryptography-vectors_41.0.3.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Test vectors for the cryptography package."
2HOMEPAGE = "https://cryptography.io/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0 | BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \
6 file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \
7 file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b"
8
9# NOTE: Make sure to keep this recipe at the same version as python3-cryptography
10# Upgrade both recipes at the same time
11
12SRC_URI[sha256sum] = "80de0452c4b34f56f5518e81ebd75b6b905f5728aaed521d42e41f4ebc8a43fb"
13
14PYPI_PACKAGE = "cryptography_vectors"
15
16inherit pypi python_setuptools_build_meta
17
18DEPENDS += " \
19 ${PYTHON_PN}-cryptography \
20"
21
22do_install:append () {
23 # Remove the sha256 checksum lines for pycache files
24 sed ${D}${PYTHON_SITEPACKAGES_DIR}/cryptography_vectors-${PV}.dist-info/RECORD -e '/__pycache__/d' -i
25}
26
27BBCLASSEXTEND = "native nativesdk"
28
29UPSTREAM_CHECK_REGEX = ""