summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-build_1.2.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-04-09 15:10:12 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-16 08:07:03 +0100
commite2f32bfd68c471732dda1af116831a7e0b07614c (patch)
tree73e035845551da125f36a09fa0f2d749239a487c /meta/recipes-devtools/python/python3-build_1.2.1.bb
parent16f33ed88a645844b47f0ae11199d81034b558fe (diff)
downloadpoky-e2f32bfd68c471732dda1af116831a7e0b07614c.tar.gz
python3-build: upgrade 1.1.1 -> 1.2.1
Changelog: ============ -Avoid error when terminal width is undetectable on Python < 3.11 -Add --installer option, supporting pip and uv. Added uv extra. -Improve console output and provide -v for dependency installation -Avoid compiling unused bytecode when using pip -Dropped support for Python 3.7 (From OE-Core rev: 83227b767299a1f8bbeb9e3b69eab8aa09fb6a07) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-build_1.2.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-build_1.2.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-build_1.2.1.bb b/meta/recipes-devtools/python/python3-build_1.2.1.bb
new file mode 100644
index 0000000000..0156861201
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-build_1.2.1.bb
@@ -0,0 +1,32 @@
1SUMMARY = "A simple, correct PEP517 package builder"
2HOMEPAGE = "https://github.com/pypa/build"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=310439af287b0fb4780b2ad6907c256c"
5
6SRC_URI[sha256sum] = "526263f4870c26f26c433545579475377b2b7588b6f1eac76a001e873ae3e19d"
7
8inherit pypi python_flit_core
9
10DEPENDS += "python3-pyproject-hooks-native"
11
12DEPENDS:remove:class-native = "python3-build-native"
13
14# Skip dependencies as we're doing a minimal build to bootstrap
15PEP517_BUILD_OPTS:class-native = "--skip-dependency-check"
16
17do_compile:prepend:class-native() {
18 export PYTHONPATH="${S}/src"
19}
20
21RDEPENDS:${PN} += " \
22 python3-compression \
23 python3-difflib \
24 python3-ensurepip \
25 python3-logging \
26 python3-packaging \
27 python3-pyproject-hooks \
28 python3-tomllib \
29 python3-venv \
30"
31
32BBCLASSEXTEND = "native nativesdk"