summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-babel_2.14.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-12-19 17:39:06 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-12-23 08:46:00 +0000
commitaaaf4043540e99bb37b683cce2a52c4a4e96ff41 (patch)
tree7b9a789ad37ea82dde77b7f0ee7f659e9c0bc12c /meta/recipes-devtools/python/python3-babel_2.14.0.bb
parent38f7a143f6f0b70126f6072e1f8e2769e7d278ab (diff)
downloadpoky-aaaf4043540e99bb37b683cce2a52c4a4e96ff41.tar.gz
python3-babel: upgrade 2.13.1 -> 2.14.0
Changelog: ============ -CLDR/Numbers: Add support of local numbering systems for number symbols -CLDR: Upgrade to CLDR 43 -Frontend: Allow last_translator to be passed as an option to extract_message -Frontend: Decouple pybabel CLI frontend from distutils/setuptools -Numbers: Improve parsing of malformed decimals (From OE-Core rev: db1967e48e44fe81af7bad54fcbb4484c9462a73) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-babel_2.14.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-babel_2.14.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-babel_2.14.0.bb b/meta/recipes-devtools/python/python3-babel_2.14.0.bb
new file mode 100644
index 0000000000..1f79a35b4d
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-babel_2.14.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "A collection of tools for internationalizing Python applications"
2HOMEPAGE = "http://babel.edgewall.org/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=0f97d9a63e91407b4c0d01efde91cfc0"
5
6SRC_URI[sha256sum] = "6919867db036398ba21eb5c7a0f6b28ab8cbc3ae7a73a44ebe34ae74a4e7d363"
7
8PYPI_PACKAGE = "Babel"
9
10inherit pypi setuptools3
11
12CLEANBROKEN = "1"
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-codecs \
16 ${PYTHON_PN}-difflib \
17 ${PYTHON_PN}-netserver \
18 ${PYTHON_PN}-numbers \
19 ${PYTHON_PN}-pickle \
20 ${PYTHON_PN}-pytz \
21 ${PYTHON_PN}-setuptools \
22 ${PYTHON_PN}-shell \
23 ${PYTHON_PN}-threading \
24"
25
26BBCLASSEXTEND = "native nativesdk"