summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-11-28 11:48:42 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-06 12:31:05 +0000
commite60be76f431dd3bf2ec57ea0271ac97c327fa95c (patch)
treed0cae55209790769ba0cf631628d1f74512e1bff /meta/recipes-devtools/python/python-smartpm_1.4.1.bb
parent69b9c6bd0c6f9c9884fa2d92b4062037457d06ad (diff)
downloadpoky-e60be76f431dd3bf2ec57ea0271ac97c327fa95c.tar.gz
python-smartpm: style fixes
* Use ${PN} instead of python-smartpm * Use multi-line strings instead of multiple single line += (also avoiding the confusing "_append +=") * Use class-native instead of virtclass-native - no difference in behaviour, but this keeps things consistent if we have to add any target overrides in future. (From OE-Core rev: 7dbe5004380b97949a7910706364ba57c6c52a33) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-smartpm_1.4.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-smartpm_1.4.1.bb48
1 files changed, 23 insertions, 25 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
index 9048bc8f02..ff153a77d0 100644
--- a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
+++ b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
@@ -28,13 +28,13 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
28# Options - rpm, qt4, gtk 28# Options - rpm, qt4, gtk
29PACKAGECONFIG ??= "rpm" 29PACKAGECONFIG ??= "rpm"
30 30
31RPM_RDEP = "python-smartpm-backend-rpm" 31RPM_RDEP = "${PN}-backend-rpm"
32QT_RDEP = "python-smartpm-interface-qt4" 32QT_RDEP = "${PN}-interface-qt4"
33GTK_RDEP = "python-smartpm-interface-gtk" 33GTK_RDEP = "${PN}-interface-gtk"
34 34
35RPM_RDEP_virtclass-native = "" 35RPM_RDEP_class-native = ""
36QT_RDEP_virtclass-native = "" 36QT_RDEP_class-native = ""
37GTK_RDEP_virtclass-native = "" 37GTK_RDEP_class-native = ""
38 38
39PACKAGECONFIG[rpm] = ",,rpm,${RPM_RDEP}" 39PACKAGECONFIG[rpm] = ",,rpm,${RPM_RDEP}"
40PACKAGECONFIG[qt4] = ",,qt4-x11,${QT_RDEP}" 40PACKAGECONFIG[qt4] = ",,qt4-x11,${QT_RDEP}"
@@ -85,35 +85,33 @@ do_install_append() {
85 fi 85 fi
86} 86}
87 87
88PACKAGES = "python-smartpm-dev python-smartpm-dbg python-smartpm-doc smartpm" 88PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc smartpm \
89PACKAGES += "${@base_contains('PACKAGECONFIG', 'rpm', 'python-smartpm-backend-rpm', '', d)}" 89 ${@base_contains('PACKAGECONFIG', 'rpm', '${PN}-backend-rpm', '', d)} \
90PACKAGES += "${@base_contains('PACKAGECONFIG', 'qt4', 'python-smartpm-interface-qt4', '', d)}" 90 ${@base_contains('PACKAGECONFIG', 'qt4', '${PN}-interface-qt4', '', d)} \
91PACKAGES += "${@base_contains('PACKAGECONFIG', 'gtk', 'python-smartpm-interface-gtk', '', d)}" 91 ${@base_contains('PACKAGECONFIG', 'gtk', '${PN}-interface-gtk', '', d)} \
92PACKAGES += "python-smartpm-interface-images" 92 ${PN}-interface-images ${PN}"
93PACKAGES += "python-smartpm"
94 93
95RDEPENDS_smartpm = 'python-smartpm' 94RDEPENDS_smartpm = "${PN}"
96 95
97RDEPENDS_python-smartpm_append = " python-smartpm-backend-rpm python-codecs python-textutils python-xml" 96RDEPENDS_${PN} += "${PN}-backend-rpm python-codecs python-textutils python-xml python-fcntl \
98RDEPENDS_python-smartpm_append += " python-fcntl python-pickle python-crypt python-compression python-shell" 97 python-pickle python-crypt python-compression python-shell \
99RDEPENDS_python-smartpm_append += " python-resource python-netclient python-threading python-unixadmin" 98 python-resource python-netclient python-threading python-unixadmin"
99RDEPENDS_${PN}_class-native = ""
100 100
101#RDEPENDS_python-smartpm_append += " python-modules" 101RDEPENDS_${PN}-backend-rpm = "python-rpm"
102 102
103RDEPENDS_python-smartpm-backend-rpm = 'python-rpm' 103RDEPENDS_${PN}-interface-qt4 = "qt4-x11 ${PN}-interface-images"
104 104RDEPENDS_${PN}-interface-gtk = "gtk+ ${PN}-interface-images"
105RDEPENDS_python-smartpm-interface-qt4 = 'qt4-x11 python-smartpm-interface-images'
106RDEPENDS_python-smartpm-interface-gtk = 'gtk+ python-smartpm-interface-images'
107 105
108FILES_smartpm = "${bindir}/smart" 106FILES_smartpm = "${bindir}/smart"
109 107
110FILES_${PN}-dbg += "${libdir}/python*/site-packages/smart/backends/rpm/.debug" 108FILES_${PN}-dbg += "${libdir}/python*/site-packages/smart/backends/rpm/.debug"
111 109
112FILES_python-smartpm-backend-rpm = "${libdir}/python*/site-packages/smart/backends/rpm" 110FILES_${PN}-backend-rpm = "${libdir}/python*/site-packages/smart/backends/rpm"
113 111
114FILES_python-smartpm-interface-qt4 = "${libdir}/python*/site-packages/smart/interfaces/qt4" 112FILES_${PN}-interface-qt4 = "${libdir}/python*/site-packages/smart/interfaces/qt4"
115FILES_python-smartpm-interface-gtk = "${libdir}/python*/site-packages/smart/interfaces/gtk" 113FILES_${PN}-interface-gtk = "${libdir}/python*/site-packages/smart/interfaces/gtk"
116FILES_python-smartpm-interface-images = "${datadir}/${baselib}/python*/site-packages/smart/interfaces/images" 114FILES_${PN}-interface-images = "${datadir}/${baselib}/python*/site-packages/smart/interfaces/images"
117 115
118BBCLASSEXTEND = "native" 116BBCLASSEXTEND = "native"
119 117