summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-07-08 00:23:48 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-09 18:00:18 +0100
commit05b02d27d2115c0af32988bb3b43286f7943471c (patch)
tree436f4bb3fef2875da1051a41630530b7aeafdae0 /meta/recipes-devtools/python/python-smartpm_1.4.1.bb
parentf9ac3f3e200e4fd0dfe0f45ddc606ce945ea0143 (diff)
downloadpoky-05b02d27d2115c0af32988bb3b43286f7943471c.tar.gz
python-smartpm: 1.4.1 -> 1.5
* Remove the following patches since the are already in the source: smart-config-ignore-all-recommends.patch smart-conflict-provider.patch smart-dflags.patch smart-filename-NAME_MAX.patch smart-flag-exclude-packages.patch smart-flag-ignore-recommends.patch smart-metadata-match.patch smart-multilib-fixes.patch smart-rpm-extra-macros.patch smart-rpm-md-parse.patch smart-rpm-root.patch smart-tmpdir.patch smart-yaml-error.patch * Update the following patches, part of the code are already in the source: smart-attempt.patch smart-improve-error-reporting.patch smart-recommends.patch smartpm-rpm5-nodig.patch * Use github and git repo as the SRC_URI. (From OE-Core rev: 5fc580fc444e45d00de0e50d32b6e6e0b2e6b7ea) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-smartpm_1.4.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-smartpm_1.4.1.bb149
1 files changed, 0 insertions, 149 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
deleted file mode 100644
index 69b94a2134..0000000000
--- a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
+++ /dev/null
@@ -1,149 +0,0 @@
1SUMMARY = "The Smart Package Manager"
2DESCRIPTION = "The Smart Package Manager project has the ambitious objective of creating \
3smart and portable algorithms for solving adequately the problem of managing software \
4upgrades and installation."
5
6HOMEPAGE = "http://labix.org/smart/"
7SECTION = "devel/python"
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833"
10
11DEPENDS = "python rpm gettext-native python-rpm"
12PR = "r9"
13SRCNAME = "smart"
14
15SRC_URI = "\
16 http://launchpad.net/smart/trunk/${PV}/+download/${SRCNAME}-${PV}.tar.bz2 \
17 file://smartpm-rpm5-nodig.patch \
18 file://smart-rpm-root.patch \
19 file://smart-recommends.patch \
20 file://smart-rpm-extra-macros.patch \
21 file://smart-dflags.patch \
22 file://smart-rpm-md-parse.patch \
23 file://smart-tmpdir.patch \
24 file://smart-metadata-match.patch \
25 file://smart-improve-error-reporting.patch \
26 file://smart-multilib-fixes.patch \
27 file://smart-yaml-error.patch \
28 file://smart-channelsdir.patch \
29 file://smart-conflict-provider.patch \
30 file://smart-flag-ignore-recommends.patch \
31 file://smart-flag-exclude-packages.patch \
32 file://smart-config-ignore-all-recommends.patch \
33 file://smart-attempt.patch \
34 file://smart-filename-NAME_MAX.patch \
35 file://smart-rpm4-fixes.patch \
36 file://smart-add-for-rpm-ignoresize-check.patch \
37 file://smart-already-installed-message.patch \
38 "
39
40SRC_URI[md5sum] = "573ef32ba177a6b3c4bf7ef04873fcb6"
41SRC_URI[sha256sum] = "b1d519ddb43d60f293b065c28870a5d9e8b591cd49e8c68caea48ace91085eba"
42S = "${WORKDIR}/${SRCNAME}-${PV}"
43
44# Options - rpm, qt4, gtk
45PACKAGECONFIG ??= "rpm"
46
47RPM_RDEP = "${PN}-backend-rpm"
48QT_RDEP = "${PN}-interface-qt4"
49GTK_RDEP = "${PN}-interface-gtk"
50
51RPM_RDEP_class-native = ""
52QT_RDEP_class-native = ""
53GTK_RDEP_class-native = ""
54
55RPM_RDEP_class-nativesdk = ""
56QT_RDEP_class-nativesdk = ""
57GTK_RDEP_class-nativesdk = ""
58
59PACKAGECONFIG[rpm] = ",,rpm,${RPM_RDEP}"
60PACKAGECONFIG[qt4] = ",,qt4-x11,${QT_RDEP}"
61PACKAGECONFIG[gtk] = ",,gtk+,${GTK_RDEP}"
62
63inherit distutils
64
65do_install_append() {
66 # We don't support the following items
67 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/slack
68 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/arch
69 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/qt
70
71 # Temporary, debian support in OE is missing the python module
72 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/aptchannelsync.py*
73 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/debdir.py*
74 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/deb
75
76 # Disable automatic channel detection
77 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/detectsys.py*
78
79 # Disable landscape support
80 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/landscape.py*
81
82 # Disable urpmi channel support
83 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/urpmichannelsync.py*
84
85 # Disable yum channel support
86 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/yumchannelsync.py*
87
88 # Disable zypper channel support
89 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/zyppchannelsync.py*
90
91 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'rpm', 'rpm', '', d)}" ]; then
92 rm -f ${D}${libdir}/python*/site-packages/smart/plugins/rpmdir.py*
93 rm -rf ${D}${libdir}/python*/site-packages/smart/backends/rpm
94 fi
95
96 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'qt4', 'qt4', '', d)}" ]; then
97 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/qt4
98 fi
99
100 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'gtk', '', d)}" ]; then
101 rm -rf ${D}${libdir}/python*/site-packages/smart/interfaces/gtk
102 fi
103}
104
105add_native_wrapper() {
106 create_wrapper ${D}/${bindir}/smart \
107 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
108 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
109 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
110}
111
112do_install_append_class-native() {
113 add_native_wrapper
114}
115
116do_install_append_class-nativesdk() {
117 add_native_wrapper
118}
119
120PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc smartpm \
121 ${@bb.utils.contains('PACKAGECONFIG', 'rpm', '${PN}-backend-rpm', '', d)} \
122 ${@bb.utils.contains('PACKAGECONFIG', 'qt4', '${PN}-interface-qt4', '', d)} \
123 ${@bb.utils.contains('PACKAGECONFIG', 'gtk', '${PN}-interface-gtk', '', d)} \
124 ${PN}-interface-images ${PN}"
125
126RDEPENDS_smartpm = "${PN}"
127
128RDEPENDS_${PN} += "${PN}-backend-rpm python-codecs python-textutils python-xml python-fcntl \
129 python-pickle python-crypt python-compression python-shell \
130 python-resource python-netclient python-threading python-unixadmin python-pprint"
131RDEPENDS_${PN}_class-native = ""
132
133RDEPENDS_${PN}-backend-rpm = "python-rpm"
134
135RDEPENDS_${PN}-interface-qt4 = "qt4-x11 ${PN}-interface-images"
136RDEPENDS_${PN}-interface-gtk = "gtk+ ${PN}-interface-images"
137
138FILES_smartpm = "${bindir}/smart"
139
140FILES_${PN}-dbg += "${libdir}/python*/site-packages/smart/backends/rpm/.debug"
141
142FILES_${PN}-backend-rpm = "${libdir}/python*/site-packages/smart/backends/rpm"
143
144FILES_${PN}-interface-qt4 = "${libdir}/python*/site-packages/smart/interfaces/qt4"
145FILES_${PN}-interface-gtk = "${libdir}/python*/site-packages/smart/interfaces/gtk"
146FILES_${PN}-interface-images = "${datadir}/${baselib}/python*/site-packages/smart/interfaces/images"
147
148BBCLASSEXTEND = "native nativesdk"
149