summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_22.0.5.bb
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2016-08-09 10:01:41 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-17 10:35:42 +0100
commitbba1b911c86557db66af4baf7f15813f43c1ae70 (patch)
tree5e5ce8c78ccb5fbc6ca1aea4f08127ca14e2de3e /meta/recipes-devtools/python/python-setuptools_22.0.5.bb
parent92f505b0162f666b14208e2835c7def9f2cd4f2c (diff)
downloadpoky-bba1b911c86557db66af4baf7f15813f43c1ae70.tar.gz
Use PYTHON_SITEPACKAGES_DIR insted of hard-coded *site-packages*
For thoese recipes that are inheriting python*-dir.bbclass, there is already a PYTHON_SITEPACKAGES_DIR present, use that definition replacing redundant "${libdir}/python*/site-packages". (From OE-Core rev: e7d842673952aa4aaa141f64958bc1344dbe8210) Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_22.0.5.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_22.0.5.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_22.0.5.bb b/meta/recipes-devtools/python/python-setuptools_22.0.5.bb
index c172039231..526474c7ea 100644
--- a/meta/recipes-devtools/python/python-setuptools_22.0.5.bb
+++ b/meta/recipes-devtools/python/python-setuptools_22.0.5.bb
@@ -7,7 +7,7 @@ DEPENDS_class-native += "python-native"
7 7
8inherit distutils 8inherit distutils
9 9
10DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages" 10DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
11 11
12RDEPENDS_${PN} = "\ 12RDEPENDS_${PN} = "\
13 python-stringold \ 13 python-stringold \