summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_18.2.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-08-26 01:40:56 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-30 12:36:07 +0100
commite79a22e4560cac0ce78a1ec04d7f799421e2b80f (patch)
tree7d52d68173cef3d734545e737bccb9acdf1710ae /meta/recipes-devtools/python/python-setuptools_18.2.bb
parent48373be8303b620fbddda3298e4eb0c8d188f7dc (diff)
downloadpoky-e79a22e4560cac0ce78a1ec04d7f799421e2b80f.tar.gz
python-distribute, python-setuptools: Migrate to good old python-setuptools
setuptools the old king is ruling again, distribute fork has been merged into setuptools starting 0.7x, so lets move to use it as well Remove licence ambiguity we need to say which verison of PSF and Zope license is in use Fixes [YOCTO #8201] (From OE-Core rev: 58d9f06b2d467dcff781fecf4cbf03b0b7e25432) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_18.2.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_18.2.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_18.2.bb b/meta/recipes-devtools/python/python-setuptools_18.2.bb
new file mode 100644
index 0000000000..1de2b2e927
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_18.2.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Downloads, builds, installs, upgrades, and uninstalls Python packages"
2HOMEPAGE = "https://pypi.python.org/pypi/setuptools"
3SECTION = "devel/python"
4LICENSE = "Python-2.0 | ZPL-2.0"
5LIC_FILES_CHKSUM = "file://setup.py;beginline=78;endline=78;md5=8a314270dd7a8dbca741775415f1716e"
6
7SRCNAME = "setuptools"
8
9PROVIDES = "python-distribute"
10
11DEPENDS += "python"
12DEPENDS_class-native += "python-native"
13
14inherit distutils
15
16SRC_URI = "https://pypi.python.org/packages/source/s/setuptools/setuptools-${PV}.tar.gz"
17SRC_URI[md5sum] = "52b4e48939ef311d7204f8fe940764f4"
18SRC_URI[sha256sum] = "0994a58df27ea5dc523782a601357a2198b7493dcc99a30d51827a23585b5b1d"
19
20S = "${WORKDIR}/${SRCNAME}-${PV}"
21
22
23DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
24
25do_install_prepend() {
26 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
27}
28
29RDEPENDS_${PN} = "\
30 python-stringold \
31 python-email \
32 python-shell \
33 python-distutils \
34 python-compression \
35"
36
37RDEPENDS_${PN}_class-native = "\
38 python-distutils \
39 python-compression \
40"
41
42RREPLACES_${PN} = "python-distribute"
43RPROVIDES_${PN} = "python-distribute"
44RCONFLICTS_${PN} = "python-distribute"
45
46BBCLASSEXTEND = "native nativesdk"