summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pygtk_2.24.0.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-07-10 00:14:55 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-12 22:55:45 +0100
commit3f71c883b8a5f48205f881d654f25f4cc32efbcc (patch)
treea7b1d3c334e575c86e5996a234086e3d755998c1 /meta/recipes-devtools/python/python-pygtk_2.24.0.bb
parentd3904caf3e5b8f9483aa784f84b340f96b5f45cb (diff)
downloadpoky-3f71c883b8a5f48205f881d654f25f4cc32efbcc.tar.gz
python-pygtk: remove invalid sed command
* There is no 'tests docs' in Makefile.am any more, so remove: sed -i 's:tests docs:tests:' ${S}/Makefile.am * Remove the invalid sed command in do_install_append, only the one for pygtk-demo is needed. (From OE-Core rev: 80f020acfa36d142edef7042e35e49f08c6b2a59) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-pygtk_2.24.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-pygtk_2.24.0.bb21
1 files changed, 0 insertions, 21 deletions
diff --git a/meta/recipes-devtools/python/python-pygtk_2.24.0.bb b/meta/recipes-devtools/python/python-pygtk_2.24.0.bb
index 053f37fcbe..e4c33a803f 100644
--- a/meta/recipes-devtools/python/python-pygtk_2.24.0.bb
+++ b/meta/recipes-devtools/python/python-pygtk_2.24.0.bb
@@ -37,31 +37,10 @@ do_configure_prepend() {
37 -e s:'`$PKG_CONFIG --variable codegendir pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/codegen\":g \ 37 -e s:'`$PKG_CONFIG --variable codegendir pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/codegen\":g \
38 -e s:'`$PKG_CONFIG --variable=fixxref pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/xsl/fixxref.py\":g \ 38 -e s:'`$PKG_CONFIG --variable=fixxref pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/xsl/fixxref.py\":g \
39 ${S}/configure.ac 39 ${S}/configure.ac
40 sed -i 's:tests docs:tests:' ${S}/Makefile.am
41} 40}
42 41
43# dirty fix #2: fix build system paths leaking in 42# dirty fix #2: fix build system paths leaking in
44do_install_append() { 43do_install_append() {
45 for i in `find ${D} -name "*.py"` ; do \
46 sed -i -e s:${D}::g $i
47 done
48
49 for i in `find ${D} -name "*.la"` ; do \
50 sed -i -e s:${STAGING_LIBDIR}:${libdir}:g $i
51 done
52
53 if test -e ${D}${bindir} ; then
54 for i in ${D}${bindir}/* ; do \
55 sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i
56 done
57 fi
58
59 if test -e ${D}${sbindir} ; then
60 for i in ${D}${sbindir}/* ; do \
61 sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i
62 done
63 fi
64
65 sed -i -e '1s|^#!.*python|#!/usr/bin/env python|' ${D}${bindir}/pygtk-demo 44 sed -i -e '1s|^#!.*python|#!/usr/bin/env python|' ${D}${bindir}/pygtk-demo
66} 45}
67 46