summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-ptyprocess_0.5.1.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-06-08 05:56:12 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-12 23:47:16 +0100
commit07c5fd7a0a2a71ceccb003ce68ff5b58242bcbb4 (patch)
tree6ee860f4681f7c11df79a935db5cb32750cc691d /meta/recipes-devtools/python/python-ptyprocess_0.5.1.bb
parent84e9f8053d97f46f637af9fb735be8e8a74b8bd0 (diff)
downloadpoky-07c5fd7a0a2a71ceccb003ce68ff5b58242bcbb4.tar.gz
python-pexpect: Upgrade from 4.0.1 to 4.1.0
Fixes source location, uses setuptools instead of distutils Adds python-ptyprocess package, since it is now a runtime dependency for python-pexpect (From OE-Core rev: 8e29f954613fbc2eb274fc7e3da1d516353c4683) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-ptyprocess_0.5.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-ptyprocess_0.5.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-ptyprocess_0.5.1.bb b/meta/recipes-devtools/python/python-ptyprocess_0.5.1.bb
new file mode 100644
index 0000000000..a9f7b4fd2c
--- /dev/null
+++ b/meta/recipes-devtools/python/python-ptyprocess_0.5.1.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Run a subprocess in a pseudo terminal"
2HOMEPAGE = "http://ptyprocess.readthedocs.io/en/latest/"
3SECTION = "devel/python"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=cfdcd51fa7d5808da4e74346ee394490"
6
7SRCNAME = "ptyprocess"
8
9SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10SRC_URI[md5sum] = "94e537122914cc9ec9c1eadcd36e73a1"
11SRC_URI[sha256sum] = "0530ce63a9295bfae7bd06edc02b6aa935619f486f0f1dc0972f516265ee81a6"
12
13UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/ptyprocess"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19RDEPENDS_${PN} = "\
20 python-core \
21"