summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.7.3.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
commit972dcfcdbfe75dcfeb777150c136576cf1a71e99 (patch)
tree97a61cd7e293d7ae9d56ef7ed0f81253365bb026 /meta/recipes-devtools/python/python-native_2.7.3.bb
downloadpoky-972dcfcdbfe75dcfeb777150c136576cf1a71e99.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.3.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.3.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.3.bb b/meta/recipes-devtools/python/python-native_2.7.3.bb
new file mode 100644
index 0000000000..e55f5feac2
--- /dev/null
+++ b/meta/recipes-devtools/python/python-native_2.7.3.bb
@@ -0,0 +1,65 @@
1require python.inc
2
3EXTRANATIVEPATH += "bzip2-native"
4DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native"
5PR = "${INC_PR}.1"
6
7SRC_URI += "\
8 file://05-enable-ctypes-cross-build.patch \
9 file://06-ctypes-libffi-fix-configure.patch \
10 file://10-distutils-fix-swig-parameter.patch \
11 file://11-distutils-never-modify-shebang-line.patch \
12 file://12-distutils-prefix-is-inside-staging-area.patch \
13 file://debug.patch \
14 file://unixccompiler.patch \
15 file://nohostlibs.patch \
16 file://multilib.patch \
17 file://add-md5module-support.patch \
18 file://builddir.patch \
19 file://parallel-makeinst-create-bindir.patch \
20 file://python-fix-build-error-with-Readline-6.3.patch \
21 file://gcc-4.8-fix-configure-Wformat.patch \
22 file://json-flaw-fix.patch \
23 "
24S = "${WORKDIR}/Python-${PV}"
25
26FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:"
27
28inherit native
29
30RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-codecs-native python-core-native"
31
32EXTRA_OECONF_append = " --bindir=${bindir}/${PN}"
33
34EXTRA_OEMAKE = '\
35 BUILD_SYS="" \
36 HOST_SYS="" \
37 LIBC="" \
38 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
39 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
40'
41
42do_configure_prepend() {
43 autoreconf --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf"
44}
45
46do_install() {
47 oe_runmake 'DESTDIR=${D}' install
48 install -d ${D}${bindir}/${PN}
49 install -m 0755 Parser/pgen ${D}${bindir}/${PN}
50
51 # Make sure we use /usr/bin/env python
52 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
53 sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
54 done
55
56 # Add a symlink to the native Python so that scripts can just invoke
57 # "nativepython" and get the right one without needing absolute paths
58 # (these often end up too long for the #! parser in the kernel as the
59 # buffer is 128 bytes long).
60 ln -s python-native/python ${D}${bindir}/nativepython
61
62 # We don't want modules in ~/.local being used in preference to those
63 # installed in the native sysroot, so disable user site support.
64 sed -i -e 's,^\(ENABLE_USER_SITE = \).*,\1False,' ${D}${libdir}/python${PYTHON_MAJMIN}/site.py
65}