summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.7.14.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-26 14:25:31 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-13 10:55:38 +0100
commit5a353c4210536df8f075281f03862a6ddcb729ef (patch)
tree745d5ae51aec5025f9adc9316998c4e03ab876f3 /meta/recipes-devtools/python/python-native_2.7.14.bb
parenta47d077ff45e7e4144d8d3dd937787bb4abb071f (diff)
downloadpoky-5a353c4210536df8f075281f03862a6ddcb729ef.tar.gz
python: Upgrade both python and python-native to 2.7.14
Rebased: - python/01-use-proper-tools-for-cross-build.patch - python/fix-makefile-for-ptest.patch - python/parallel-makeinst-create-bindir.patch Removed Upstreamed Patch: - python/Don-t-use-getentropy-on-Linux.patch Updated license checksum for changes in the copyright date. The license terms remain unchanged Added an extra do_compile item to create the native pgen that no longer gets compiled by default (From OE-Core rev: 9f2de4f9cf1eb6de75dc789bd0549f45c7a68c55) (From OE-Core rev: 00bdc9752e76fb66bb7eb8d6c3249aa031f14fdb) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> [Bug fix release only] CVE-2017-9233 CVE-2016-0718 CVE-2012-0876 CVE-2016-4472 Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.14.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.14.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.14.bb b/meta/recipes-devtools/python/python-native_2.7.14.bb
new file mode 100644
index 0000000000..8fe4bcac16
--- /dev/null
+++ b/meta/recipes-devtools/python/python-native_2.7.14.bb
@@ -0,0 +1,67 @@
1require python.inc
2
3EXTRANATIVEPATH += "bzip2-native"
4DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native expat-native"
5PR = "${INC_PR}.1"
6
7SRC_URI += "\
8 file://05-enable-ctypes-cross-build.patch \
9 file://10-distutils-fix-swig-parameter.patch \
10 file://11-distutils-never-modify-shebang-line.patch \
11 file://0001-distutils-set-the-prefix-to-be-inside-staging-direct.patch \
12 file://debug.patch \
13 file://unixccompiler.patch \
14 file://nohostlibs.patch \
15 file://multilib.patch \
16 file://add-md5module-support.patch \
17 file://builddir.patch \
18 file://parallel-makeinst-create-bindir.patch \
19 file://revert_use_of_sysconfigdata.patch \
20 "
21
22S = "${WORKDIR}/Python-${PV}"
23
24FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:"
25
26inherit native
27
28require python-native-${PYTHON_MAJMIN}-manifest.inc
29
30EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --with-system-expat=${STAGING_DIR_HOST}"
31
32EXTRA_OEMAKE = '\
33 LIBC="" \
34 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
35 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
36'
37
38do_configure_append() {
39 autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
40}
41
42# Regenerate all of the generated files
43# This ensures that pgen and friends get created during the compile phase
44do_compile_prepend() {
45 oe_runmake regen-all
46}
47
48do_install() {
49 oe_runmake 'DESTDIR=${D}' install
50 install -d ${D}${bindir}/${PN}
51 install -m 0755 Parser/pgen ${D}${bindir}/${PN}
52
53 # Make sure we use /usr/bin/env python
54 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
55 sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
56 done
57
58 # Add a symlink to the native Python so that scripts can just invoke
59 # "nativepython" and get the right one without needing absolute paths
60 # (these often end up too long for the #! parser in the kernel as the
61 # buffer is 128 bytes long).
62 ln -s python-native/python ${D}${bindir}/nativepython
63
64 # We don't want modules in ~/.local being used in preference to those
65 # installed in the native sysroot, so disable user site support.
66 sed -i -e 's,^\(ENABLE_USER_SITE = \).*,\1False,' ${D}${libdir}/python${PYTHON_MAJMIN}/site.py
67}