summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.6.6.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-11-08 10:34:46 -0800
committerSaul Wold <sgw@linux.intel.com>2010-11-14 21:08:26 -0800
commit793bb465b3a6b0c883340621575b9944d7ccaf5a (patch)
treeb668cfadf3836b3d018dd76005f3bb65b4f8dd03 /meta/recipes-devtools/python/python-native_2.6.6.bb
parenta7af5c516e547e669d92569dba21a9c1c790cf7f (diff)
downloadpoky-793bb465b3a6b0c883340621575b9944d7ccaf5a.tar.gz
python, python-native upgrade from 2.6.5 to 2.6.6
Removed these patch: python-native-2.6.5/00-fix-bindir-libdir-for-cross.patch python/00-fix-bindir-libdir-for-cross.patch The upstream code has changed, and it does not need the above 2 patches (fixes) anymore. Patches rebased to the newer code: python/01-use-proper-tools-for-cross-build.patch python/04-default-is-optimized.patch python/06-avoid_usr_lib_termcap_path_in_linking.patch python/99-ignore-optimization-flag.patch Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.6.6.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.6.6.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.6.6.bb b/meta/recipes-devtools/python/python-native_2.6.6.bb
new file mode 100644
index 0000000000..148dc587e9
--- /dev/null
+++ b/meta/recipes-devtools/python/python-native_2.6.6.bb
@@ -0,0 +1,30 @@
1require python.inc
2DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native"
3PR = "${INC_PR}.0"
4
5
6SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
7 file://04-default-is-optimized.patch \
8 file://05-enable-ctypes-cross-build.patch \
9 file://10-distutils-fix-swig-parameter.patch \
10 file://11-distutils-never-modify-shebang-line.patch \
11 file://12-distutils-prefix-is-inside-staging-area.patch \
12 file://debug.patch \
13 file://nohostlibs.patch"
14S = "${WORKDIR}/Python-${PV}"
15
16inherit native
17
18EXTRA_OEMAKE = '\
19 BUILD_SYS="" \
20 HOST_SYS="" \
21 LIBC="" \
22 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
23 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
24'
25
26do_install() {
27 oe_runmake 'DESTDIR=${D}' install
28 install -d ${D}${bindir}/
29 install -m 0755 Parser/pgen ${D}${bindir}/
30}