summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-imaging_1.1.7.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-02 12:25:57 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-03 13:13:27 +0100
commit68cea002055bba97a6eff3b4f15773a58ee399ac (patch)
treee3829ea77793be588d76617c350e1f9f79f6d808 /meta/recipes-devtools/python/python-imaging_1.1.7.bb
parent5cd554fbe255bd460c81226fb61e3c87fc75304d (diff)
downloadpoky-68cea002055bba97a6eff3b4f15773a58ee399ac.tar.gz
python-imaging: remove unused recipe
(From OE-Core rev: b03ebfaee278eb98b4bd0e11a682ac0cda192086) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-imaging_1.1.7.bb')
-rw-r--r--meta/recipes-devtools/python/python-imaging_1.1.7.bb45
1 files changed, 0 insertions, 45 deletions
diff --git a/meta/recipes-devtools/python/python-imaging_1.1.7.bb b/meta/recipes-devtools/python/python-imaging_1.1.7.bb
deleted file mode 100644
index a678328275..0000000000
--- a/meta/recipes-devtools/python/python-imaging_1.1.7.bb
+++ /dev/null
@@ -1,45 +0,0 @@
1SUMMARY = "Python Imaging Library (PIL)"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://README;beginline=92;endline=120;md5=c4371af4579f1e489cf881c1443dd4ec"
5DEPENDS = "freetype jpeg tiff"
6SRCNAME = "Imaging"
7PR = "r5"
8
9SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
10 file://0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch \
11 file://allow.to.disable.some.features.patch \
12 file://fix-freetype-includes.patch"
13
14SRC_URI[md5sum] = "fc14a54e1ce02a0225be8854bfba478e"
15SRC_URI[sha256sum] = "895bc7c2498c8e1f9b99938f1a40dc86b3f149741f105cf7c7bd2e0725405211"
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18# There isn't enable/disable option, and lcms is in meta-oe, at least make it explicit when enabled
19# setup.py already has FIXME: add mechanism to explicitly *disable* the use of a library
20PACKAGECONFIG ??= ""
21PACKAGECONFIG[lcms] = ",,lcms"
22
23inherit distutils
24
25do_compile() {
26 export STAGING_LIBDIR=${STAGING_LIBDIR}
27 export STAGING_INCDIR=${STAGING_INCDIR}
28 export LCMS_ENABLED=${@bb.utils.contains('PACKAGECONFIG', 'lcms', 'True', 'False', d)}
29 distutils_do_compile
30}
31
32do_install() {
33 export STAGING_LIBDIR=${STAGING_LIBDIR}
34 export STAGING_INCDIR=${STAGING_INCDIR}
35 export LCMS_ENABLED=${@bb.utils.contains('PACKAGECONFIG', 'lcms', 'True', 'False', d)}
36 distutils_do_install
37 install -d ${D}${datadir}/doc/${BPN}/html/
38 install -m 0644 ${S}/README ${D}${datadir}/doc/${BPN}/
39 install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${BPN}/html/
40
41 # get rid of #!/usr/local/bin/python
42 sed -i -e 's:/usr/local/bin/:${bindir}/env :g' ${D}${bindir}/*
43}
44
45RDEPENDS_${PN} += "python-lang python-stringold"