summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-imaging_1.1.7.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-07-21 15:45:41 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-29 13:09:09 +0100
commit4154db3fe7285384f5baaf83287e92780ea3159c (patch)
treedaa946b0b66cd57d51a7d441b4d2a0fd0ba28e4e /meta/recipes-devtools/python/python-imaging_1.1.7.bb
parent6d891358c5fba47dd63642e87edefd247d7f9e68 (diff)
downloadpoky-4154db3fe7285384f5baaf83287e92780ea3159c.tar.gz
python-imaging: add PACKAGECONFIG for lcms
* it's autodetected from sysroot * add PACKAGECONFIG to make it deterministic (From OE-Core rev: c11aaac4952320f565bd65ec5f601c50763408a7) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-imaging_1.1.7.bb')
-rw-r--r--meta/recipes-devtools/python/python-imaging_1.1.7.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-imaging_1.1.7.bb b/meta/recipes-devtools/python/python-imaging_1.1.7.bb
index de0e975127..e100358d08 100644
--- a/meta/recipes-devtools/python/python-imaging_1.1.7.bb
+++ b/meta/recipes-devtools/python/python-imaging_1.1.7.bb
@@ -7,23 +7,31 @@ SRCNAME = "Imaging"
7PR = "r5" 7PR = "r5"
8 8
9SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \ 9SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
10 file://0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch" 10 file://0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch \
11 file://allow.to.disable.some.features.patch"
11 12
12SRC_URI[md5sum] = "fc14a54e1ce02a0225be8854bfba478e" 13SRC_URI[md5sum] = "fc14a54e1ce02a0225be8854bfba478e"
13SRC_URI[sha256sum] = "895bc7c2498c8e1f9b99938f1a40dc86b3f149741f105cf7c7bd2e0725405211" 14SRC_URI[sha256sum] = "895bc7c2498c8e1f9b99938f1a40dc86b3f149741f105cf7c7bd2e0725405211"
14S = "${WORKDIR}/${SRCNAME}-${PV}" 15S = "${WORKDIR}/${SRCNAME}-${PV}"
15 16
17# There isn't enable/disable option, and lcms is in meta-oe, at least make it explicit when enabled
18# setup.py already has FIXME: add mechanism to explicitly *disable* the use of a library
19PACKAGECONFIG ??= ""
20PACKAGECONFIG[lcms] = ",,lcms"
21
16inherit distutils 22inherit distutils
17 23
18do_compile() { 24do_compile() {
19 export STAGING_LIBDIR=${STAGING_LIBDIR} 25 export STAGING_LIBDIR=${STAGING_LIBDIR}
20 export STAGING_INCDIR=${STAGING_INCDIR} 26 export STAGING_INCDIR=${STAGING_INCDIR}
27 export LCMS_ENABLED=${@base_contains('PACKAGECONFIG', 'lcms', 'True', 'False', d)}
21 distutils_do_compile 28 distutils_do_compile
22} 29}
23 30
24do_install() { 31do_install() {
25 export STAGING_LIBDIR=${STAGING_LIBDIR} 32 export STAGING_LIBDIR=${STAGING_LIBDIR}
26 export STAGING_INCDIR=${STAGING_INCDIR} 33 export STAGING_INCDIR=${STAGING_INCDIR}
34 export LCMS_ENABLED=${@base_contains('PACKAGECONFIG', 'lcms', 'True', 'False', d)}
27 distutils_do_install 35 distutils_do_install
28 install -d ${D}${datadir}/doc/${BPN}/html/ 36 install -d ${D}${datadir}/doc/${BPN}/html/
29 install -m 0644 ${S}/README ${D}${datadir}/doc/${BPN}/ 37 install -m 0644 ${S}/README ${D}${datadir}/doc/${BPN}/