summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-git_1.0.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-02-24 17:55:04 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-28 11:33:05 +0000
commitf53f374445054b5d6018d71159b0c798b487f52b (patch)
treec4f3f2db20b04a327f60f53c6d35319e92b137b3 /meta/recipes-devtools/python/python-git_1.0.2.bb
parentec73437b4adc60b0d63a08d3eff6b26d756386cc (diff)
downloadpoky-f53f374445054b5d6018d71159b0c798b487f52b.tar.gz
python-git: update to 1.0.2
(From OE-Core rev: 77f69822a3a3c1ddc62f0c5e4e6657534d034b1d) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-git_1.0.2.bb')
-rw-r--r--meta/recipes-devtools/python/python-git_1.0.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-git_1.0.2.bb b/meta/recipes-devtools/python/python-git_1.0.2.bb
new file mode 100644
index 0000000000..f00f805a8e
--- /dev/null
+++ b/meta/recipes-devtools/python/python-git_1.0.2.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Python library used to interact with Git repositories"
2DESCRIPTION = "GitPython provides object model read and write access to \
3a git repository. Access repository information conveniently, alter the \
4index directly, handle remotes, or go down to low-level object database \
5access with big-files support."
6HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
10DEPENDS = "python-gitdb"
11
12SRC_URI = "http://pypi.python.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz"
13
14SRC_URI[md5sum] = "d92d96a8da0fc77cf141d3e16084e094"
15SRC_URI[sha256sum] = "85de72556781480a38897a77de5b458ae3838b0fd589593679a1b5f34d181d84"
16
17UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/GitPython/"
18UPSTREAM_CHECK_REGEX = "/GitPython/(?P<pver>(\d+[\.\-_]*)+)"
19
20S = "${WORKDIR}/GitPython-${PV}"
21
22inherit setuptools
23
24RDEPENDS_${PN} += "python-gitdb python-lang python-io python-shell python-math python-re python-subprocess python-stringold python-unixadmin"
25
26BBCLASSEXTEND = "nativesdk"