summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python-numpy/python3-numpy_1.20.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2021-02-17 13:52:01 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-18 23:40:00 +0000
commit5c142018f05a322667b957adf295a2e230b2d2d8 (patch)
tree228d918d68dc35e1db6a2b341825a88f2b477256 /meta/recipes-devtools/python-numpy/python3-numpy_1.20.0.bb
parent184de46110cdf4d861d3efb51018db89d66a4b8d (diff)
downloadpoky-5c142018f05a322667b957adf295a2e230b2d2d8.tar.gz
python3-numpy: upgrade 1.20.0 -> 1.20.1
License-Update: change in copyright years (From OE-Core rev: 62021582bec5c4aa503fb554d9bf67343b5c57c0) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python-numpy/python3-numpy_1.20.0.bb')
-rw-r--r--meta/recipes-devtools/python-numpy/python3-numpy_1.20.0.bb56
1 files changed, 0 insertions, 56 deletions
diff --git a/meta/recipes-devtools/python-numpy/python3-numpy_1.20.0.bb b/meta/recipes-devtools/python-numpy/python3-numpy_1.20.0.bb
deleted file mode 100644
index 8d348d85ca..0000000000
--- a/meta/recipes-devtools/python-numpy/python3-numpy_1.20.0.bb
+++ /dev/null
@@ -1,56 +0,0 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
3LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & BSD & MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=474c7e8e97b80fb7500de2b0c4a4a8d4"
5
6SRCNAME = "numpy"
7
8SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
9 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
10 file://0001-numpy-core-Define-RISCV-32-support.patch \
11 file://run-ptest \
12"
13SRC_URI[sha256sum] = "67b630745a71b541ff6517d6f3d62b00690dc8ba0684cad0d7b0ac55aec1de53"
14
15UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
16UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
17
18DEPENDS += "python3-cython-native"
19
20inherit ptest setuptools3
21
22S = "${WORKDIR}/numpy-${PV}"
23
24CLEANBROKEN = "1"
25
26FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
27
28# install what is needed for numpy.test()
29RDEPENDS_${PN} = "${PYTHON_PN}-unittest \
30 ${PYTHON_PN}-difflib \
31 ${PYTHON_PN}-pprint \
32 ${PYTHON_PN}-pickle \
33 ${PYTHON_PN}-shell \
34 ${PYTHON_PN}-doctest \
35 ${PYTHON_PN}-datetime \
36 ${PYTHON_PN}-distutils \
37 ${PYTHON_PN}-misc \
38 ${PYTHON_PN}-mmap \
39 ${PYTHON_PN}-netclient \
40 ${PYTHON_PN}-numbers \
41 ${PYTHON_PN}-pydoc \
42 ${PYTHON_PN}-pkgutil \
43 ${PYTHON_PN}-email \
44 ${PYTHON_PN}-compression \
45 ${PYTHON_PN}-ctypes \
46 ${PYTHON_PN}-threading \
47 ${PYTHON_PN}-multiprocessing \
48"
49RDEPENDS_${PN}-ptest += "${PYTHON_PN}-pytest \
50 ${PYTHON_PN}-hypothesis \
51 ${PYTHON_PN}-sortedcontainers \
52 ${PYTHON_PN}-resource \
53 ldd \
54"
55
56BBCLASSEXTEND = "native nativesdk"