summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2018-03-08 20:18:01 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-09 09:17:04 -0800
commite5f5aa5604a7617af839832ded457c8a824bcf2f (patch)
tree00e727d032b3abaaf545d07c578d80e415abfd79 /meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb
parentd1d088db2879f1fefeebda0da815c1138fa52256 (diff)
downloadpoky-e5f5aa5604a7617af839832ded457c8a824bcf2f.tar.gz
python-numpy: update to 1.14.1
Drop backported 0001-BUG-fix-infinite-loop-when-creating-np.pad-on-an-emp.patch. Drop 0001-BUG-fix-infinite-loop-when-creating-np.pad-on-an-emp.patch as upstream is using os.path.basename() instead now. License-Update: License.txt file was update to list licenses of individual components; not all of them are 3-clause BSD. (From OE-Core rev: c70d1c07e4e697156bd49c43e2cc800f3085b182) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb')
-rw-r--r--meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb115
1 files changed, 0 insertions, 115 deletions
diff --git a/meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb b/meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb
deleted file mode 100644
index b6ec2308e4..0000000000
--- a/meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb
+++ /dev/null
@@ -1,115 +0,0 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1002b09cd654fcaa2dcc87535acd9a96"
5
6SRCNAME = "numpy"
7
8SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
9 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
10 file://remove-build-path-in-comments.patch \
11 file://fix_shebang_f2py.patch \
12 file://0001-BUG-fix-infinite-loop-when-creating-np.pad-on-an-emp.patch \
13 ${CONFIGFILESURI} "
14
15SRC_URI[md5sum] = "6d459e4a24f5035f720dda3c57716a92"
16SRC_URI[sha256sum] = "de020ec06f1e9ce1115a50161a38bf8d4c2525379900f9cb478cc613a1e7cd93"
17
18UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
19UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
20
21CONFIGFILESURI ?= ""
22
23CONFIGFILESURI_aarch64 = " \
24 file://config.h \
25 file://_numpyconfig.h \
26"
27CONFIGFILESURI_arm = " \
28 file://config.h \
29 file://numpyconfig.h \
30"
31CONFIGFILESURI_armeb = " \
32 file://config.h \
33 file://numpyconfig.h \
34"
35CONFIGFILESURI_mipsarcho32el = " \
36 file://config.h \
37 file://numpyconfig.h \
38"
39CONFIGFILESURI_x86 = " \
40 file://config.h \
41 file://numpyconfig.h \
42"
43CONFIGFILESURI_x86-64 = " \
44 file://config.h \
45 file://_numpyconfig.h \
46"
47CONFIGFILESURI_mipsarcho32eb = " \
48 file://config.h \
49 file://_numpyconfig.h \
50"
51CONFIGFILESURI_powerpc = " \
52 file://config.h \
53 file://_numpyconfig.h \
54"
55CONFIGFILESURI_powerpc64 = " \
56 file://config.h \
57 file://_numpyconfig.h \
58"
59CONFIGFILESURI_mipsarchn64eb = " \
60 file://config.h \
61 file://_numpyconfig.h \
62"
63CONFIGFILESURI_mipsarchn64el = " \
64 file://config.h \
65 file://_numpyconfig.h \
66"
67CONFIGFILESURI_mipsarchn32eb = " \
68 file://config.h \
69 file://_numpyconfig.h \
70"
71CONFIGFILESURI_mipsarchn32el = " \
72 file://config.h \
73 file://_numpyconfig.h \
74"
75
76S = "${WORKDIR}/numpy-${PV}"
77
78inherit setuptools
79
80# Make the build fail and replace *config.h with proper one
81# This is a ugly, ugly hack - Koen
82do_compile_prepend_class-target() {
83 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
84 true
85 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
86}
87
88FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
89
90# install what is needed for numpy.test()
91RDEPENDS_${PN} = "python-unittest \
92 python-difflib \
93 python-pprint \
94 python-pickle \
95 python-shell \
96 python-nose \
97 python-doctest \
98 python-datetime \
99 python-distutils \
100 python-misc \
101 python-mmap \
102 python-netclient \
103 python-numbers \
104 python-pydoc \
105 python-pkgutil \
106 python-email \
107 python-subprocess \
108 python-compression \
109 python-ctypes \
110 python-threading \
111"
112
113RDEPENDS_${PN}_class-native = ""
114
115BBCLASSEXTEND = "native nativesdk"