summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-09 07:19:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-13 09:27:38 +0100
commit9b32a558f663502d119b94264fa6cfa98086cb52 (patch)
treead94e8731c3f894960fa533a280be7b7deaa8f7e /meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb
parent43d52e785b42a9b38419ae2959cc5983bd017deb (diff)
downloadpoky-9b32a558f663502d119b94264fa6cfa98086cb52.tar.gz
python-numpy: Upgrade to 1.13.1
Update LICENSE to BSD-3-Clause as per https://github.com/numpy/numpy/blob/master/LICENSE.txt LIC_FILES_CHKSUM changed due to copyright year change see https://github.com/numpy/numpy/commit/b2ff4f13197dd58508d3d025a9034519974750bd (From OE-Core rev: a703bb6159dd69020fb40db7a6a0811f45869972) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb')
-rw-r--r--meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb113
1 files changed, 113 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb b/meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb
new file mode 100644
index 0000000000..63821d30fa
--- /dev/null
+++ b/meta/recipes-devtools/python-numpy/python-numpy_1.13.1.bb
@@ -0,0 +1,113 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1002b09cd654fcaa2dcc87535acd9a96"
5
6SRCNAME = "numpy"
7
8SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
9 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
10 file://remove-build-path-in-comments.patch \
11 file://fix_shebang_f2py.patch \
12 ${CONFIGFILESURI} "
13
14SRC_URI[md5sum] = "6d459e4a24f5035f720dda3c57716a92"
15SRC_URI[sha256sum] = "de020ec06f1e9ce1115a50161a38bf8d4c2525379900f9cb478cc613a1e7cd93"
16
17UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
18
19CONFIGFILESURI ?= ""
20
21CONFIGFILESURI_aarch64 = " \
22 file://config.h \
23 file://_numpyconfig.h \
24"
25CONFIGFILESURI_arm = " \
26 file://config.h \
27 file://numpyconfig.h \
28"
29CONFIGFILESURI_armeb = " \
30 file://config.h \
31 file://numpyconfig.h \
32"
33CONFIGFILESURI_mipsarcho32el = " \
34 file://config.h \
35 file://numpyconfig.h \
36"
37CONFIGFILESURI_x86 = " \
38 file://config.h \
39 file://numpyconfig.h \
40"
41CONFIGFILESURI_x86-64 = " \
42 file://config.h \
43 file://_numpyconfig.h \
44"
45CONFIGFILESURI_mipsarcho32eb = " \
46 file://config.h \
47 file://_numpyconfig.h \
48"
49CONFIGFILESURI_powerpc = " \
50 file://config.h \
51 file://_numpyconfig.h \
52"
53CONFIGFILESURI_powerpc64 = " \
54 file://config.h \
55 file://_numpyconfig.h \
56"
57CONFIGFILESURI_mipsarchn64eb = " \
58 file://config.h \
59 file://_numpyconfig.h \
60"
61CONFIGFILESURI_mipsarchn64el = " \
62 file://config.h \
63 file://_numpyconfig.h \
64"
65CONFIGFILESURI_mipsarchn32eb = " \
66 file://config.h \
67 file://_numpyconfig.h \
68"
69CONFIGFILESURI_mipsarchn32el = " \
70 file://config.h \
71 file://_numpyconfig.h \
72"
73
74S = "${WORKDIR}/numpy-${PV}"
75
76inherit setuptools
77
78# Make the build fail and replace *config.h with proper one
79# This is a ugly, ugly hack - Koen
80do_compile_prepend_class-target() {
81 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
82 true
83 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
84}
85
86FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
87
88# install what is needed for numpy.test()
89RDEPENDS_${PN} = "python-unittest \
90 python-difflib \
91 python-pprint \
92 python-pickle \
93 python-shell \
94 python-nose \
95 python-doctest \
96 python-datetime \
97 python-distutils \
98 python-misc \
99 python-mmap \
100 python-netclient \
101 python-numbers \
102 python-pydoc \
103 python-pkgutil \
104 python-email \
105 python-subprocess \
106 python-compression \
107 python-ctypes \
108 python-threading \
109"
110
111RDEPENDS_${PN}_class-native = ""
112
113BBCLASSEXTEND = "native nativesdk"