summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/prelink/prelink_git.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-28 23:28:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-02 15:44:10 +0100
commitbb6ddc3691ab04162ec5fd69a2d5e7876713fd15 (patch)
tree76e376b01253c3aace1a98a5021bcaad3c92e861 /meta/recipes-devtools/prelink/prelink_git.bb
parentfcc456ee4b8f619134abb4649db53c638074082c (diff)
downloadpoky-bb6ddc3691ab04162ec5fd69a2d5e7876713fd15.tar.gz
Convert to new override syntax
This is the result of automated script conversion: scripts/contrib/convert-overrides.py <oe-core directory> converting the metadata to use ":" as the override character instead of "_". (From OE-Core rev: 42344347be29f0997cc2f7636d9603b1fe1875ae) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/prelink/prelink_git.bb')
-rw-r--r--meta/recipes-devtools/prelink/prelink_git.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-devtools/prelink/prelink_git.bb b/meta/recipes-devtools/prelink/prelink_git.bb
index e197af9ee9..78d4c71817 100644
--- a/meta/recipes-devtools/prelink/prelink_git.bb
+++ b/meta/recipes-devtools/prelink/prelink_git.bb
@@ -19,11 +19,11 @@ PV = "1.0+git${SRCPV}"
19# 19#
20# Default is prelinking is enabled. 20# Default is prelinking is enabled.
21# 21#
22SUMMARY_${PN}-cron = "Cron scripts to control automatic prelinking" 22SUMMARY:${PN}-cron = "Cron scripts to control automatic prelinking"
23DESCRIPTION_${PN}-cron = "Cron scripts to control automatic prelinking. \ 23DESCRIPTION:${PN}-cron = "Cron scripts to control automatic prelinking. \
24See: ${sysconfdir}/cron.daily/prelink for configuration information." 24See: ${sysconfdir}/cron.daily/prelink for configuration information."
25 25
26FILES_${PN}-cron = "${sysconfdir}/cron.daily ${sysconfdir}/default" 26FILES:${PN}-cron = "${sysconfdir}/cron.daily ${sysconfdir}/default"
27 27
28PACKAGES =+ "${PN}-cron" 28PACKAGES =+ "${PN}-cron"
29 29
@@ -37,10 +37,10 @@ SRC_URI = "git://git.yoctoproject.org/prelink-cross.git;branch=cross_prelink_sta
37UPSTREAM_CHECK_COMMITS = "1" 37UPSTREAM_CHECK_COMMITS = "1"
38 38
39# error: error.h: No such file or directory 39# error: error.h: No such file or directory
40COMPATIBLE_HOST_libc-musl = 'null' 40COMPATIBLE_HOST:libc-musl = 'null'
41 41
42TARGET_OS_ORIG := "${TARGET_OS}" 42TARGET_OS_ORIG := "${TARGET_OS}"
43OVERRIDES_append = ":${TARGET_OS_ORIG}" 43OVERRIDES:append = ":${TARGET_OS_ORIG}"
44 44
45S = "${WORKDIR}/git" 45S = "${WORKDIR}/git"
46 46
@@ -144,12 +144,12 @@ python () {
144 bb.build.addtask('do_linkerpaths', 'do_configure', 'do_patch', d) 144 bb.build.addtask('do_linkerpaths', 'do_configure', 'do_patch', d)
145} 145}
146 146
147do_configure_prepend () { 147do_configure:prepend () {
148 # Disable documentation! 148 # Disable documentation!
149 echo "all:" > ${S}/doc/Makefile.am 149 echo "all:" > ${S}/doc/Makefile.am
150} 150}
151 151
152do_install_append () { 152do_install:append () {
153 install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default ${D}${sysconfdir}/rpm 153 install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default ${D}${sysconfdir}/rpm
154 install -m 0644 ${WORKDIR}/prelink.conf ${D}${sysconfdir}/prelink.conf 154 install -m 0644 ${WORKDIR}/prelink.conf ${D}${sysconfdir}/prelink.conf
155 install -m 0644 ${WORKDIR}/prelink.cron.daily ${D}${sysconfdir}/cron.daily/prelink 155 install -m 0644 ${WORKDIR}/prelink.cron.daily ${D}${sysconfdir}/cron.daily/prelink
@@ -161,7 +161,7 @@ do_install_append () {
161# Prelinking during a cross install should be handled by the image-prelink 161# Prelinking during a cross install should be handled by the image-prelink
162# bbclass. If the user desires this to run on the target at first boot 162# bbclass. If the user desires this to run on the target at first boot
163# they will need to create a custom boot script. 163# they will need to create a custom boot script.
164pkg_postinst_prelink() { 164pkg_postinst:prelink() {
165#!/bin/sh 165#!/bin/sh
166 166
167if [ "x$D" != "x" ]; then 167if [ "x$D" != "x" ]; then
@@ -171,7 +171,7 @@ fi
171prelink -a 171prelink -a
172} 172}
173 173
174pkg_prerm_prelink() { 174pkg_prerm:prelink() {
175#!/bin/sh 175#!/bin/sh
176 176
177if [ "x$D" != "x" ]; then 177if [ "x$D" != "x" ]; then