summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pkgconfig/pkgconfig_git.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-07-17 09:20:15 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-21 22:51:37 +0100
commitfedac61ad973981b824a2c79ffc9feaa6d754dba (patch)
tree04010f526351861775a17c311f4eb5343ccacaf4 /meta/recipes-devtools/pkgconfig/pkgconfig_git.bb
parentd98a2f4df0963fe14fff85650185642c51b63c97 (diff)
downloadpoky-fedac61ad973981b824a2c79ffc9feaa6d754dba.tar.gz
pkgconfig: allow kernel to be build with esdk
When the kernel's menuconfig target is called while using the esdk or an esdk-based container, the pkg-config info that is found is not correct. The pkg-config info is for the target, but we need the eSDK's information in order to build the host based menuconfig. The new pkg-config-esdk script checks both that it's in SDK and being called from the check-lxdialog script in order to limit the scope of when the pkg-config automagically switches to pkg-config-native. The pkg-config-esdk is only installed as pkg-config inside the eSDK, which is why we use the sstate post install script and check for if we are in the esdk environment using the WITHIN_EXT_SDK [YOCTO #11155] (From OE-Core rev: 0954452d151613fa758fbde8ee9469b30d80776b) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/pkgconfig/pkgconfig_git.bb')
-rw-r--r--meta/recipes-devtools/pkgconfig/pkgconfig_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pkgconfig/pkgconfig_git.bb b/meta/recipes-devtools/pkgconfig/pkgconfig_git.bb
index e6340218e0..52ef2a9779 100644
--- a/meta/recipes-devtools/pkgconfig/pkgconfig_git.bb
+++ b/meta/recipes-devtools/pkgconfig/pkgconfig_git.bb
@@ -12,6 +12,7 @@ SRCREV = "edf8e6f0ea77ede073f07bff0d2ae1fc7a38103b"
12PV = "0.29.2+git${SRCPV}" 12PV = "0.29.2+git${SRCPV}"
13 13
14SRC_URI = "git://anongit.freedesktop.org/pkg-config \ 14SRC_URI = "git://anongit.freedesktop.org/pkg-config \
15 file://pkg-config-esdk.in \
15 file://pkg-config-native.in \ 16 file://pkg-config-native.in \
16 file://fix-glib-configure-libtool-usage.patch \ 17 file://fix-glib-configure-libtool-usage.patch \
17 file://0001-glib-gettext.m4-Update-AM_GLIB_GNU_GETTEXT-to-match-.patch \ 18 file://0001-glib-gettext.m4-Update-AM_GLIB_GNU_GETTEXT-to-match-.patch \
@@ -54,4 +55,19 @@ do_install_append_class-native () {
54 -e "s|@LIBDIR_NATIVE@|${PKG_CONFIG_LIBDIR}|" \ 55 -e "s|@LIBDIR_NATIVE@|${PKG_CONFIG_LIBDIR}|" \
55 < ${WORKDIR}/pkg-config-native.in > ${B}/pkg-config-native 56 < ${WORKDIR}/pkg-config-native.in > ${B}/pkg-config-native
56 install -m755 ${B}/pkg-config-native ${D}${bindir}/pkg-config-native 57 install -m755 ${B}/pkg-config-native ${D}${bindir}/pkg-config-native
58 sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \
59 -e "s|@LIBDIR_NATIVE@|${PKG_CONFIG_LIBDIR}|" \
60 < ${WORKDIR}/pkg-config-esdk.in > ${B}/pkg-config-esdk
61 install -m755 ${B}/pkg-config-esdk ${D}${bindir}/pkg-config-esdk
57} 62}
63
64pkgconfig_sstate_fixup_esdk () {
65 if [ "${BB_CURRENTTASK}" = "populate_sysroot_setscene" -a "${WITHIN_EXT_SDK}" = "1" ] ; then
66 pkgconfdir="${SSTATE_INSTDIR}/recipe-sysroot-native/${bindir_native}"
67 mv $pkgconfdir/pkg-config $pkgconfdir/pkg-config.real
68 lnr $pkgconfdir/pkg-config-esdk $pkgconfdir/pkg-config
69 sed -i -e "s|^pkg-config|pkg-config.real|" $pkgconfdir/pkg-config-native
70 fi
71}
72
73SSTATEPOSTUNPACKFUNCS_append_class-native = " pkgconfig_sstate_fixup_esdk"