summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.24.1.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2017-02-21 12:34:51 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-01 23:27:06 +0000
commit95a4f9aa12c4f6cfec2aa13fb4195f20504486f6 (patch)
tree3e666264bbcbf191aa40510becb9700d669a16fe /meta/recipes-devtools/perl/perl_5.24.1.bb
parent2d238896de3dd946022eab4c447243bd33641a14 (diff)
downloadpoky-95a4f9aa12c4f6cfec2aa13fb4195f20504486f6.tar.gz
perl: Upgrade to 5.24.1
Upgrade config.sh to match new version. Removed CVE patches already in upstream: - perl-fix-CVE-2016-1238.patch - perl-fix-CVE-2016-6185.patch Update customized.dat patch to match new hashes. (From OE-Core rev: f3f1614b87aa5c55653fe8f3247fb094baf98087) Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.24.1.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.24.1.bb371
1 files changed, 371 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.24.1.bb b/meta/recipes-devtools/perl/perl_5.24.1.bb
new file mode 100644
index 0000000000..147e151d74
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl_5.24.1.bb
@@ -0,0 +1,371 @@
1require perl.inc
2
3# We need gnugrep (for -I)
4DEPENDS = "virtual/db grep-native"
5DEPENDS += "gdbm zlib"
6
7# Pick up patches from debian
8# http://ftp.de.debian.org/debian/pool/main/p/perl/perl_5.22.0-1.debian.tar.xz
9SRC_URI += " \
10 file://debian/cpan_definstalldirs.diff \
11 file://debian/db_file_ver.diff \
12 file://debian/doc_info.diff \
13 file://debian/enc2xs_inc.diff \
14 file://debian/errno_ver.diff \
15 file://debian/libperl_embed_doc.diff \
16 file://debian/fixes/respect_umask.diff \
17 file://debian/writable_site_dirs.diff \
18 file://debian/extutils_set_libperl_path.diff \
19 file://debian/no_packlist_perllocal.diff \
20 file://debian/prefix_changes.diff \
21 file://debian/instmodsh_doc.diff \
22 file://debian/ld_run_path.diff \
23 file://debian/libnet_config_path.diff \
24 file://debian/mod_paths.diff \
25 file://debian/prune_libs.diff \
26 file://debian/fixes/net_smtp_docs.diff \
27 file://debian/perlivp.diff \
28 file://debian/squelch-locale-warnings.diff \
29 file://debian/skip-upstream-git-tests.diff \
30 file://debian/skip-kfreebsd-crash.diff \
31 file://debian/fixes/document_makemaker_ccflags.diff \
32 file://debian/find_html2text.diff \
33 file://debian/perl5db-x-terminal-emulator.patch \
34 file://debian/cpan-missing-site-dirs.diff \
35 file://debian/fixes/memoize_storable_nstore.diff \
36 file://debian/regen-skip.diff \
37"
38
39SRC_URI += " \
40 file://Makefile.patch \
41 file://Makefile.SH.patch \
42 file://installperl.patch \
43 file://perl-archlib-exp.patch \
44 file://perl-dynloader.patch \
45 file://perl-moreconfig.patch \
46 file://letgcc-find-errno.patch \
47 file://generate-sh.patch \
48 file://native-perlinc.patch \
49 file://perl-enable-gdbm.patch \
50 file://cross-generate_uudmap.patch \
51 file://fix_bad_rpath.patch \
52 file://dynaloaderhack.patch \
53 file://config.sh \
54 file://config.sh-32 \
55 file://config.sh-32-le \
56 file://config.sh-32-be \
57 file://config.sh-64 \
58 file://config.sh-64-le \
59 file://config.sh-64-be \
60 file://make_ext.pl-fix-regenerate-makefile-failed-while-cc-.patch \
61 file://t-run-switches.t-perl5-perl.patch \
62 file://ext-ODBM_File-hints-linux.pl-link-libgdbm_compat.patch \
63 file://ext-ODBM_File-t-odbm.t-fix-the-path-of-dbmt_common.p.patch \
64 file://perl-PathTools-don-t-filter-out-blib-from-INC.patch \
65 file://perl-errno-generation-gcc5.patch \
66 file://perl-fix-conflict-between-skip_all-and-END.patch \
67 file://perl-test-customized.patch \
68"
69
70# Fix test case issues
71SRC_URI_append_class-target = " \
72 file://test/dist-threads-t-join.t-adjust-ps-option.patch \
73 file://test/ext-DynaLoader-t-DynaLoader.t-fix-calling-dl_findfil.patch \
74 "
75
76SRC_URI[md5sum] = "af6a84c7c3e2b8b269c105a5db2f6d53"
77SRC_URI[sha256sum] = "03a77bac4505c270f1890ece75afc7d4b555090b41aa41ea478747e23b2afb3f"
78
79inherit perlnative siteinfo
80
81# Where to find the native perl
82HOSTPERL = "${STAGING_BINDIR_NATIVE}/perl-native/perl${PV}"
83
84# Where to find .so files - use the -native versions not those from the target build
85export PERLHOSTLIB = "${STAGING_LIBDIR_NATIVE}/perl-native/perl/${PV}/"
86
87# Where to find perl @INC/#include files
88# - use the -native versions not those from the target build
89export PERL_LIB = "${STAGING_LIBDIR_NATIVE}/perl-native/perl/${PV}/"
90export PERL_ARCHLIB = "${STAGING_LIBDIR_NATIVE}/perl-native/perl/${PV}/"
91
92EXTRA_OEMAKE = "-e MAKEFLAGS="
93
94# LDFLAGS for shared libraries
95export LDDLFLAGS = "${LDFLAGS} -shared"
96
97LDFLAGS_append = " -fstack-protector"
98
99# We're almost Debian, aren't we?
100CFLAGS += "-DDEBIAN"
101
102do_nolargefile() {
103 sed -i -e "s,\(uselargefiles=\)'define',\1'undef',g" \
104 -e "s,\(d_readdir64_r=\)'define',\1'undef',g" \
105 -e "s,\(readdir64_r_proto=\)'\w+',\1'0',g" \
106 -e "/ccflags_uselargefiles/d" \
107 -e "s/-Duselargefiles//" \
108 -e "s/-D_FILE_OFFSET_BITS=64//" \
109 -e "s/-D_LARGEFILE_SOURCE//" \
110 ${S}/Cross/config.sh-${TARGET_ARCH}-${TARGET_OS}
111}
112
113do_configure() {
114 # Make hostperl in build directory be the native perl
115 ln -sf ${HOSTPERL} hostperl
116
117 if [ -n "${CONFIGURESTAMPFILE}" -a -e "${CONFIGURESTAMPFILE}" ]; then
118 if [ "`cat ${CONFIGURESTAMPFILE}`" != "${BB_TASKHASH}" -a -e Makefile ]; then
119 ${MAKE} clean
120 fi
121 find ${S} -name *.so -delete
122 fi
123 if [ -n "${CONFIGURESTAMPFILE}" ]; then
124 echo ${BB_TASKHASH} > ${CONFIGURESTAMPFILE}
125 fi
126
127 # Do our work in the cross subdir
128 cd Cross
129
130 # Generate configuration
131 rm -f config.sh-${TARGET_ARCH}-${TARGET_OS}
132 for i in ${WORKDIR}/config.sh \
133 ${WORKDIR}/config.sh-${SITEINFO_BITS} \
134 ${WORKDIR}/config.sh-${SITEINFO_BITS}-${SITEINFO_ENDIANNESS}; do
135 cat $i >> config.sh-${TARGET_ARCH}-${TARGET_OS}
136 done
137
138 # Fixups for uclibc
139 if [ "${TARGET_OS}" = "linux-uclibc" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
140 sed -i -e "s,\(d_crypt_r=\)'define',\1'undef',g" \
141 -e "s,\(d_futimes=\)'define',\1'undef',g" \
142 -e "s,\(d_finitel=\)'define',\1'undef',g" \
143 -e "s,\(crypt_r_proto=\)'\w+',\1'0',g" \
144 -e "s,\(d_getnetbyname_r=\)'define',\1'undef',g" \
145 -e "s,\(getnetbyname_r_proto=\)'\w+',\1'0',g" \
146 -e "s,\(d_getnetbyaddr_r=\)'define',\1'undef',g" \
147 -e "s,\(getnetbyaddr_r_proto=\)'\w+',\1'0',g" \
148 -e "s,\(d_getnetent_r=\)'define',\1'undef',g" \
149 -e "s,\(getnetent_r_proto=\)'\w+',\1'0',g" \
150 -e "s,\(d_sockatmark=\)'define',\1'undef',g" \
151 -e "s,\(d_sockatmarkproto=\)'\w+',\1'0',g" \
152 -e "s,\(d_eaccess=\)'define',\1'undef',g" \
153 -e "s,\(d_stdio_ptr_lval=\)'define',\1'undef',g" \
154 -e "s,\(d_stdio_ptr_lval_sets_cnt=\)'define',\1'undef',g" \
155 -e "s,\(d_stdiobase=\)'define',\1'undef',g" \
156 -e "s,\(d_stdstdio=\)'define',\1'undef',g" \
157 -e "s,-fstack-protector,-fno-stack-protector,g" \
158 config.sh-${TARGET_ARCH}-${TARGET_OS}
159 fi
160 # Fixups for musl
161 if [ "${TARGET_OS}" = "linux-musl" -o "${TARGET_OS}" = "linux-musleabi" ]; then
162 sed -i -e "s,\(d_libm_lib_version=\)'define',\1'undef',g" \
163 -e "s,\(d_stdio_ptr_lval=\)'define',\1'undef',g" \
164 -e "s,\(d_stdio_ptr_lval_sets_cnt=\)'define',\1'undef',g" \
165 -e "s,\(d_stdiobase=\)'define',\1'undef',g" \
166 -e "s,\(d_stdstdio=\)'define',\1'undef',g" \
167 -e "s,\(d_getnetbyname_r=\)'define',\1'undef',g" \
168 -e "s,\(d_finitel=\)'define',\1'undef',g" \
169 -e "s,\(getprotobyname_r=\)'define',\1'undef',g" \
170 -e "s,\(getpwent_r=\)'define',\1'undef',g" \
171 -e "s,\(getservent_r=\)'define',\1'undef',g" \
172 -e "s,\(gethostent_r=\)'define',\1'undef',g" \
173 -e "s,\(getnetent_r=\)'define',\1'undef',g" \
174 -e "s,\(getnetbyaddr_r=\)'define',\1'undef',g" \
175 -e "s,\(getprotoent_r=\)'define',\1'undef',g" \
176 -e "s,\(getprotobynumber_r=\)'define',\1'undef',g" \
177 -e "s,\(getgrent_r=\)'define',\1'undef',g" \
178 -e "s,\(i_fcntl=\)'undef',\1'define',g" \
179 -e "s,\(h_fcntl=\)'false',\1'true',g" \
180 -e "s,-fstack-protector,-fno-stack-protector,g" \
181 -e "s,-lnsl,,g" \
182 config.sh-${TARGET_ARCH}-${TARGET_OS}
183 fi
184
185 ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '', 'do_nolargefile', d)}
186
187 # Update some paths in the configuration
188 sed -i -e 's,@ARCH@-thread-multi,,g' \
189 -e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \
190 -e 's,@STAGINGDIR@,${STAGING_DIR_HOST},g' \
191 -e "s,@INCLUDEDIR@,${STAGING_INCDIR},g" \
192 -e "s,@LIBDIR@,${libdir},g" \
193 -e "s,@BASELIBDIR@,${base_libdir},g" \
194 -e "s,@EXECPREFIX@,${exec_prefix},g" \
195 -e 's,@USRBIN@,${bindir},g' \
196 config.sh-${TARGET_ARCH}-${TARGET_OS}
197
198 case "${TARGET_ARCH}" in
199 x86_64 | powerpc | s390)
200 sed -i -e "s,\(need_va_copy=\)'undef',\1'define',g" \
201 config.sh-${TARGET_ARCH}-${TARGET_OS}
202 ;;
203 arm)
204 sed -i -e "s,\(d_u32align=\)'undef',\1'define',g" \
205 config.sh-${TARGET_ARCH}-${TARGET_OS}
206 ;;
207 esac
208 # These are strewn all over the source tree
209 for foo in `grep -I --exclude="*.patch" --exclude="*.diff" --exclude="*.pod" --exclude="README*" -m1 "/usr/include/.*\.h" ${S}/* -r -l` ${S}/utils/h2xs.PL ; do
210 echo Fixing: $foo
211 sed -e 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i $foo
212 done
213
214 rm -f config
215 echo "ARCH = ${TARGET_ARCH}" > config
216 echo "OS = ${TARGET_OS}" >> config
217}
218
219do_compile() {
220 # Fix to avoid recursive substitution of path
221 sed -i -e 's|(@libpath, ".*"|(@libpath, "${STAGING_LIBDIR}"|g' cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist/Kid.pm
222
223 cd Cross
224 oe_runmake perl LD="${CCLD}"
225}
226
227do_install() {
228 #export hostperl="${STAGING_BINDIR_NATIVE}/perl-native/perl${PV}"
229 oe_runmake install DESTDIR=${D}
230 # Add perl pointing at current version
231 ln -sf perl${PV} ${D}${bindir}/perl
232
233 ln -sf perl ${D}/${libdir}/perl5
234
235 # Remove unwanted file and empty directories
236 rm -f ${D}/${libdir}/perl/${PV}/.packlist
237 rmdir ${D}/${libdir}/perl/site_perl/${PV}
238 rmdir ${D}/${libdir}/perl/site_perl
239
240 # Fix up shared library
241 mv ${D}/${libdir}/perl/${PV}/CORE/libperl.so ${D}/${libdir}/libperl.so.${PV}
242 ln -sf libperl.so.${PV} ${D}/${libdir}/libperl.so.5
243 ln -sf ../../../libperl.so.${PV} ${D}/${libdir}/perl/${PV}/CORE/libperl.so
244
245 # target config, used by cpan.bbclass to extract version information
246 install config.sh ${D}${libdir}/perl
247
248 ln -s Config_heavy.pl ${D}${libdir}/perl/${PV}/Config_heavy-target.pl
249}
250
251do_install_append_class-nativesdk () {
252 create_wrapper ${D}${bindir}/perl \
253 PERL5LIB='$PERL5LIB:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl/site_perl/${PV}:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl/vendor_perl/${PV}:$OECORE_NATIVE_SYSROOT/${libdir_nativesdk}/perl/${PV}'
254}
255
256PACKAGE_PREPROCESS_FUNCS += "perl_package_preprocess"
257
258perl_package_preprocess () {
259 # Fix up installed configuration
260 sed -i -e "s,${D},,g" \
261 -e "s,--sysroot=${STAGING_DIR_HOST},,g" \
262 -e "s,-isystem${STAGING_INCDIR} ,,g" \
263 -e "s,${STAGING_LIBDIR},${libdir},g" \
264 -e "s,${STAGING_BINDIR},${bindir},g" \
265 -e "s,${STAGING_INCDIR},${includedir},g" \
266 -e "s,${STAGING_BINDIR_NATIVE}/perl-native/,${bindir}/,g" \
267 -e "s,${STAGING_BINDIR_NATIVE}/,,g" \
268 -e "s,${STAGING_BINDIR_TOOLCHAIN}/${TARGET_PREFIX},${bindir},g" \
269 ${PKGD}${bindir}/h2xs \
270 ${PKGD}${bindir}/h2ph \
271 ${PKGD}${bindir}/pod2man \
272 ${PKGD}${bindir}/pod2text \
273 ${PKGD}${bindir}/pod2usage \
274 ${PKGD}${bindir}/podchecker \
275 ${PKGD}${bindir}/podselect \
276 ${PKGD}${libdir}/perl/${PV}/CORE/config.h \
277 ${PKGD}${libdir}/perl/${PV}/CORE/perl.h \
278 ${PKGD}${libdir}/perl/${PV}/CORE/pp.h \
279 ${PKGD}${libdir}/perl/${PV}/Config.pm \
280 ${PKGD}${libdir}/perl/${PV}/Config.pod \
281 ${PKGD}${libdir}/perl/${PV}/Config_heavy.pl \
282 ${PKGD}${libdir}/perl/${PV}/ExtUtils/Liblist/Kid.pm \
283 ${PKGD}${libdir}/perl/${PV}/FileCache.pm \
284 ${PKGD}${libdir}/perl/${PV}/pod/*.pod \
285 ${PKGD}${libdir}/perl/config.sh
286}
287
288PACKAGES = "perl-dbg perl perl-misc perl-dev perl-pod perl-doc perl-lib \
289 perl-module-cpan perl-module-cpanplus perl-module-unicore"
290FILES_${PN} = "${bindir}/perl ${bindir}/perl${PV} \
291 ${libdir}/perl/${PV}/Config.pm \
292 ${libdir}/perl/${PV}/strict.pm \
293 ${libdir}/perl/${PV}/warnings.pm \
294 ${libdir}/perl/${PV}/warnings \
295 ${libdir}/perl/${PV}/vars.pm \
296 "
297FILES_${PN}_append_class-nativesdk = " ${bindir}/perl.real"
298RPROVIDES_${PN} += "perl-module-strict perl-module-vars perl-module-config perl-module-warnings \
299 perl-module-warnings-register"
300FILES_${PN}-dev = "${libdir}/perl/${PV}/CORE"
301FILES_${PN}-lib = "${libdir}/libperl.so* \
302 ${libdir}/perl5 \
303 ${libdir}/perl/config.sh \
304 ${libdir}/perl/${PV}/Config_heavy.pl \
305 ${libdir}/perl/${PV}/Config_heavy-target.pl"
306FILES_${PN}-pod = "${libdir}/perl/${PV}/pod \
307 ${libdir}/perl/${PV}/*.pod \
308 ${libdir}/perl/${PV}/*/*.pod \
309 ${libdir}/perl/${PV}/*/*/*.pod "
310FILES_perl-misc = "${bindir}/*"
311FILES_${PN}-doc = "${libdir}/perl/${PV}/*/*.txt \
312 ${libdir}/perl/${PV}/*/*/*.txt \
313 ${libdir}/perl/${PV}/auto/XS/Typemap \
314 ${libdir}/perl/${PV}/B/assemble \
315 ${libdir}/perl/${PV}/B/cc_harness \
316 ${libdir}/perl/${PV}/B/disassemble \
317 ${libdir}/perl/${PV}/B/makeliblinks \
318 ${libdir}/perl/${PV}/CGI/eg \
319 ${libdir}/perl/${PV}/CPAN/PAUSE2003.pub \
320 ${libdir}/perl/${PV}/CPAN/SIGNATURE \
321 ${libdir}/perl/${PV}/CPANPLUS/Shell/Default/Plugins/HOWTO.pod \
322 ${libdir}/perl/${PV}/Encode/encode.h \
323 ${libdir}/perl/${PV}/ExtUtils/MANIFEST.SKIP \
324 ${libdir}/perl/${PV}/ExtUtils/NOTES \
325 ${libdir}/perl/${PV}/ExtUtils/PATCHING \
326 ${libdir}/perl/${PV}/ExtUtils/typemap \
327 ${libdir}/perl/${PV}/ExtUtils/xsubpp \
328 ${libdir}/perl/${PV}/ExtUtils/Changes_EU-Install \
329 ${libdir}/perl/${PV}/Net/*.eg \
330 ${libdir}/perl/${PV}/unicore/mktables \
331 ${libdir}/perl/${PV}/unicore/mktables.lst \
332 ${libdir}/perl/${PV}/unicore/version "
333
334FILES_perl-module-cpan += "${libdir}/perl/${PV}/CPAN \
335 ${libdir}/perl/${PV}/CPAN.pm"
336FILES_perl-module-cpanplus += "${libdir}/perl/${PV}/CPANPLUS \
337 ${libdir}/perl/${PV}/CPANPLUS.pm"
338FILES_perl-module-unicore += "${libdir}/perl/${PV}/unicore"
339
340# Create a perl-modules package recommending all the other perl
341# packages (actually the non modules packages and not created too)
342ALLOW_EMPTY_perl-modules = "1"
343PACKAGES_append = " perl-modules "
344
345PACKAGESPLITFUNCS_prepend = "split_perl_packages "
346
347python split_perl_packages () {
348 libdir = d.expand('${libdir}/perl/${PV}')
349 do_split_packages(d, libdir, 'auto/([^.]*)/[^/]*\.(so|ld|ix|al)', 'perl-module-%s', 'perl module %s', recursive=True, match_path=True, prepend=False)
350 do_split_packages(d, libdir, 'Module/([^\/]*)\.pm', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
351 do_split_packages(d, libdir, 'Module/([^\/]*)/.*', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
352 do_split_packages(d, libdir, '(^(?!(CPAN\/|CPANPLUS\/|Module\/|unicore\/|auto\/)[^\/]).*)\.(pm|pl|e2x)', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
353
354 # perl-modules should recommend every perl module, and only the
355 # modules. Don't attempt to use the result of do_split_packages() as some
356 # modules are manually split (eg. perl-module-unicore).
357 packages = filter(lambda p: 'perl-module-' in p, d.getVar('PACKAGES').split())
358 d.setVar(d.expand("RRECOMMENDS_${PN}-modules"), ' '.join(packages))
359}
360
361PACKAGES_DYNAMIC += "^perl-module-.*"
362PACKAGES_DYNAMIC_class-nativesdk += "^nativesdk-perl-module-.*"
363
364RPROVIDES_perl-lib = "perl-lib"
365
366require perl-rdepends_${PV}.inc
367require perl-ptest.inc
368
369SSTATE_SCAN_FILES += "*.pm *.pod *.h *.pl *.sh"
370
371BBCLASSEXTEND = "nativesdk"