summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.14.2.bb
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2012-12-18 18:16:28 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-07 11:09:36 +0000
commit61583fe11f2494e37ec0dd6e3bdeadf33f25f199 (patch)
treee29f0d343260bfc62819c1c4e1133211943284a0 /meta/recipes-devtools/perl/perl_5.14.2.bb
parent52c6393375d49ca469aa9e6bfcc608b74fcb1c44 (diff)
downloadpoky-61583fe11f2494e37ec0dd6e3bdeadf33f25f199.tar.gz
perl: add sub-package perl-tests
In perl source code, run "make test" will run perl test cases. Put these cases into a seprated sub-package then we can run the perl test on target. Add following module to nonxs_ext to install extra modules that required by perl test cases: CPAN/Meta CPAN/Meta/YAML Dumpvalue Env File/CheckTree HTTP/Tiny I18N/Collate JSON/PP Perl/OSType Version/Requirements Commands to run test: cd /opt/perl-tests/t && ./TEST [Yocto 3296] (From OE-Core rev: 96fb96ddd00881947875518df832fa74faec8a45) Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.14.2.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.14.2.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.14.2.bb b/meta/recipes-devtools/perl/perl_5.14.2.bb
index 4dac5ceb86..8cff7f58cf 100644
--- a/meta/recipes-devtools/perl/perl_5.14.2.bb
+++ b/meta/recipes-devtools/perl/perl_5.14.2.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
7# We need gnugrep (for -I) 7# We need gnugrep (for -I)
8DEPENDS = "virtual/db grep-native" 8DEPENDS = "virtual/db grep-native"
9DEPENDS += "gdbm zlib" 9DEPENDS += "gdbm zlib"
10PR = "r15" 10PR = "r16"
11 11
12# 5.10.1 has Module::Build built-in 12# 5.10.1 has Module::Build built-in
13PROVIDES += "libmodule-build-perl" 13PROVIDES += "libmodule-build-perl"
@@ -319,6 +319,7 @@ RPROVIDES_perl-lib = "perl-lib"
319require perl-rdepends_${PV}.inc 319require perl-rdepends_${PV}.inc
320require perl-rprovides.inc 320require perl-rprovides.inc
321require perl-rprovides_${PV}.inc 321require perl-rprovides_${PV}.inc
322include perl-tests.inc
322 323
323SSTATE_SCAN_FILES += "*.pm *.pod *.h *.pl *.sh" 324SSTATE_SCAN_FILES += "*.pm *.pod *.h *.pl *.sh"
324 325