summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.14.2.bb
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2013-01-21 16:57:12 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-25 12:42:48 +0000
commit526498282688c6e110727c9184efd1b69997c9db (patch)
tree96f2869b1983b070fc4bbd72eeb31aa1f9d5149c /meta/recipes-devtools/perl/perl_5.14.2.bb
parente80f02a93b1c717e6bc7001a05c773290ca68992 (diff)
downloadpoky-526498282688c6e110727c9184efd1b69997c9db.tar.gz
perl: update to 5.14.3
There is a securty issue: http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2012-5195 Update perl to 5.14.3 to resolve this problem. Patches hurd-ccflags.diff, h2ph-multiarch.diff, index-tainting.diff and hurd-hints.diff have been merged, so remove them from SRC_URI. Update patches config.sh and Makefile.SH.patch with new PV. [Yocto 3701] (From OE-Core rev: b1fd25e05308cabb56afe1d4276470bf7380ea59) Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.14.2.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.14.2.bb328
1 files changed, 0 insertions, 328 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.14.2.bb b/meta/recipes-devtools/perl/perl_5.14.2.bb
deleted file mode 100644
index df702474d1..0000000000
--- a/meta/recipes-devtools/perl/perl_5.14.2.bb
+++ /dev/null
@@ -1,328 +0,0 @@
1DESCRIPTION = "Perl is a popular scripting language."
2HOMEPAGE = "http://www.perl.org/"
3SECTION = "devel"
4LICENSE = "Artistic-1.0 | GPL-1.0"
5LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
6 file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
7# We need gnugrep (for -I)
8DEPENDS = "virtual/db grep-native"
9DEPENDS += "gdbm zlib"
10PR = "r18"
11
12# 5.10.1 has Module::Build built-in
13PROVIDES += "libmodule-build-perl"
14
15SRC_URI = "http://www.cpan.org/src/5.0/perl-${PV}.tar.gz \
16 file://debian/arm_thread_stress_timeout.diff \
17 file://debian/cpan_definstalldirs.diff \
18 file://debian/db_file_ver.diff \
19 file://debian/doc_info.diff \
20 file://debian/enc2xs_inc.diff \
21 file://debian/errno_ver.diff \
22 file://debian/libperl_embed_doc.diff \
23 file://debian/fixes/respect_umask.diff \
24 file://debian/writable_site_dirs.diff \
25 file://debian/extutils_set_libperl_path.diff \
26 file://debian/no_packlist_perllocal.diff \
27 file://debian/prefix_changes.diff \
28 file://debian/fakeroot.diff \
29 file://debian/instmodsh_doc.diff \
30 file://debian/ld_run_path.diff \
31 file://debian/libnet_config_path.diff \
32 file://debian/m68k_thread_stress.diff \
33 file://debian/mod_paths.diff \
34 file://debian/module_build_man_extensions.diff \
35 file://debian/prune_libs.diff \
36 file://debian/fixes/net_smtp_docs.diff \
37 file://debian/perlivp.diff \
38 file://debian/disable-zlib-bundling.diff \
39 file://debian/cpanplus_definstalldirs.diff \
40 file://debian/cpanplus_config_path.diff \
41 file://debian/deprecate-with-apt.diff \
42 file://debian/fixes/hurd-ccflags.diff \
43 file://debian/squelch-locale-warnings.diff \
44 file://debian/skip-upstream-git-tests.diff \
45 file://debian/fixes/extutils-cbuilder-cflags.diff \
46 file://debian/fixes/module-build-home-directory.diff \
47 file://debian/fixes/h2ph-multiarch.diff \
48 file://debian/fixes/index-tainting.diff \
49 file://debian/skip-kfreebsd-crash.diff \
50 file://debian/fixes/document_makemaker_ccflags.diff \
51 file://debian/fixes/sys-syslog-socket-timeout-kfreebsd.patch \
52 file://debian/fixes/hurd-hints.diff \
53 file://debian/fixes/pod_fixes.diff \
54 file://debian/find_html2text.diff \
55 \
56 file://Makefile.patch \
57 file://Makefile.SH.patch \
58 file://installperl.patch \
59 file://perl-dynloader.patch \
60 file://perl-moreconfig.patch \
61 file://letgcc-find-errno.patch \
62 file://generate-sh.patch \
63 file://09_fix_installperl.patch \
64 file://native-perlinc.patch \
65 file://perl-enable-gdbm.patch \
66 file://cross-generate_uudmap.patch \
67 file://fix_bad_rpath.patch \
68 file://perl-build-in-t-dir.patch \
69 file://perl-archlib-exp.patch \
70 file://dynaloaderhack.patch \
71 \
72 file://config.sh \
73 file://config.sh-32 \
74 file://config.sh-32-le \
75 file://config.sh-32-be \
76 file://config.sh-64 \
77 file://config.sh-64-le \
78 file://config.sh-64-be"
79# file://debian/fakeroot.diff
80
81SRC_URI[md5sum] = "3306fbaf976dcebdcd49b2ac0be00eb9"
82SRC_URI[sha256sum] = "6488359573bd7d41761bf935f66f827dc220fb3df961ef9b775d51fbd66548d3"
83
84inherit perlnative siteinfo
85
86# Where to find the native perl
87HOSTPERL = "${STAGING_BINDIR_NATIVE}/perl-native/perl${PV}"
88
89# Where to find .so files - use the -native versions not those from the target build
90export PERLHOSTLIB = "${STAGING_LIBDIR_NATIVE}/perl-native/perl/${PV}/"
91
92# LDFLAGS for shared libraries
93export LDDLFLAGS = "${LDFLAGS} -shared"
94
95LDFLAGS_append = " -fstack-protector"
96
97# We're almost Debian, aren't we?
98CFLAGS += "-DDEBIAN"
99
100do_nolargefile() {
101 sed -i -e "s,\(uselargefiles=\)'define',\1'undef',g" \
102 -e "s,\(d_readdir64_r=\)'define',\1'undef',g" \
103 -e "s,\(readdir64_r_proto=\)'\w+',\1'0',g" \
104 -e "/ccflags_uselargefiles/d" \
105 -e "s/-Duselargefiles//" \
106 -e "s/-D_FILE_OFFSET_BITS=64//" \
107 -e "s/-D_LARGEFILE_SOURCE//" \
108 ${S}/Cross/config.sh-${TARGET_ARCH}-${TARGET_OS}
109}
110
111do_configure() {
112 # Make hostperl in build directory be the native perl
113 ln -sf ${HOSTPERL} hostperl
114
115 # Do our work in the cross subdir
116 cd Cross
117
118 # Generate configuration
119 rm -f config.sh-${TARGET_ARCH}-${TARGET_OS}
120 for i in ${WORKDIR}/config.sh \
121 ${WORKDIR}/config.sh-${SITEINFO_BITS} \
122 ${WORKDIR}/config.sh-${SITEINFO_BITS}-${SITEINFO_ENDIANNESS}; do
123 cat $i >> config.sh-${TARGET_ARCH}-${TARGET_OS}
124 done
125
126 # Fixups for uclibc
127 if [ "${TARGET_OS}" = "linux-uclibc" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
128 sed -i -e "s,\(d_crypt_r=\)'define',\1'undef',g" \
129 -e "s,\(d_futimes=\)'define',\1'undef',g" \
130 -e "s,\(crypt_r_proto=\)'\w+',\1'0',g" \
131 -e "s,\(d_getnetbyname_r=\)'define',\1'undef',g" \
132 -e "s,\(getnetbyname_r_proto=\)'\w+',\1'0',g" \
133 -e "s,\(d_getnetbyaddr_r=\)'define',\1'undef',g" \
134 -e "s,\(getnetbyaddr_r_proto=\)'\w+',\1'0',g" \
135 -e "s,\(d_getnetent_r=\)'define',\1'undef',g" \
136 -e "s,\(getnetent_r_proto=\)'\w+',\1'0',g" \
137 -e "s,\(d_sockatmark=\)'define',\1'undef',g" \
138 -e "s,\(d_sockatmarkproto=\)'\w+',\1'0',g" \
139 -e "s,\(d_eaccess=\)'define',\1'undef',g" \
140 -e "s,\(d_stdio_ptr_lval=\)'define',\1'undef',g" \
141 -e "s,\(d_stdio_ptr_lval_sets_cnt=\)'define',\1'undef',g" \
142 -e "s,\(d_stdiobase=\)'define',\1'undef',g" \
143 -e "s,\(d_stdstdio=\)'define',\1'undef',g" \
144 -e "s,-fstack-protector,-fno-stack-protector,g" \
145 config.sh-${TARGET_ARCH}-${TARGET_OS}
146 fi
147
148 ${@base_contains('DISTRO_FEATURES', 'largefile', '', 'do_nolargefile', d)}
149
150 # Update some paths in the configuration
151 sed -i -e 's,@ARCH@-thread-multi,,g' \
152 -e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \
153 -e 's,@STAGINGDIR@,${STAGING_DIR_HOST},g' \
154 -e "s,@INCLUDEDIR@,${STAGING_INCDIR},g" \
155 -e "s,@LIBDIR@,${libdir},g" \
156 -e "s,@BASELIBDIR@,${base_libdir},g" \
157 -e "s,@EXECPREFIX@,${exec_prefix},g" \
158 -e 's,@USRBIN@,${bindir},g' \
159 config.sh-${TARGET_ARCH}-${TARGET_OS}
160
161 case "${TARGET_ARCH}" in
162 x86_64 | powerpc | s390)
163 sed -i -e "s,\(need_va_copy=\)'undef',\1'define',g" \
164 config.sh-${TARGET_ARCH}-${TARGET_OS}
165 ;;
166 arm)
167 sed -i -e "s,\(d_u32align=\)'undef',\1'define',g" \
168 config.sh-${TARGET_ARCH}-${TARGET_OS}
169 ;;
170 esac
171 # These are strewn all over the source tree
172 for foo in `grep -I --exclude="*.patch" --exclude="*.diff" --exclude="*.pod" --exclude="README*" -m1 "/usr/include/.*\.h" ${S}/* -r -l` ${S}/utils/h2xs.PL ; do
173 echo Fixing: $foo
174 sed -e 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i $foo
175 done
176
177 rm -f config
178 echo "ARCH = ${TARGET_ARCH}" > config
179 echo "OS = ${TARGET_OS}" >> config
180}
181
182do_compile() {
183 # Fix to avoid recursive substitution of path
184 sed -i -e "s|\([ \"\']\+\)/usr/include|\1${STAGING_INCDIR}|g" ext/Errno/Errno_pm.PL
185 sed -i -e "s|\([ \"\']\+\)/usr/include|\1${STAGING_INCDIR}|g" cpan/Compress-Raw-Zlib/config.in
186 sed -i -e 's|/usr/lib|""|g' cpan/Compress-Raw-Zlib/config.in
187 sed -i -e 's|SYSROOTLIB|${STAGING_LIBDIR}|g' cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist/Kid.pm
188
189 cd Cross
190 oe_runmake perl LD="${CCLD}"
191}
192
193do_install() {
194 oe_runmake install DESTDIR=${D}
195 # Add perl pointing at current version
196 ln -sf perl${PV} ${D}${bindir}/perl
197
198 ln -sf perl ${D}/${libdir}/perl5
199
200 # Remove unwanted file and empty directories
201 rm -f ${D}/${libdir}/perl/${PV}/.packlist
202 rmdir ${D}/${libdir}/perl/site_perl/${PV}
203 rmdir ${D}/${libdir}/perl/site_perl
204
205 # Fix up shared library
206 mv ${D}/${libdir}/perl/${PV}/CORE/libperl.so ${D}/${libdir}/libperl.so.${PV}
207 ln -sf libperl.so.${PV} ${D}/${libdir}/libperl.so.5
208 ln -sf ../../../libperl.so.${PV} ${D}/${libdir}/perl/${PV}/CORE/libperl.so
209
210 # target config, used by cpan.bbclass to extract version information
211 install config.sh ${D}${libdir}/perl
212
213 ln -s Config_heavy.pl ${D}${libdir}/perl/${PV}/Config_heavy-target.pl
214
215}
216
217PACKAGE_PREPROCESS_FUNCS += "perl_package_preprocess"
218
219perl_package_preprocess () {
220 # Fix up installed configuration
221 sed -i -e "s,${D},,g" \
222 -e "s,-isystem${STAGING_INCDIR} ,,g" \
223 -e "s,${STAGING_LIBDIR},${libdir},g" \
224 -e "s,${STAGING_BINDIR},${bindir},g" \
225 -e "s,${STAGING_INCDIR},${includedir},g" \
226 -e "s,${STAGING_BINDIR_NATIVE}/perl-native/,${bindir}/,g" \
227 -e "s,${STAGING_BINDIR_NATIVE}/,,g" \
228 ${PKGD}${bindir}/h2xs \
229 ${PKGD}${bindir}/h2ph \
230 ${PKGD}${bindir}/pod2man \
231 ${PKGD}${bindir}/pod2text \
232 ${PKGD}${bindir}/pod2usage \
233 ${PKGD}${bindir}/podchecker \
234 ${PKGD}${bindir}/podselect \
235 ${PKGD}${libdir}/perl/${PV}/pod/*.pod \
236 ${PKGD}${libdir}/perl/${PV}/cacheout.pl \
237 ${PKGD}${libdir}/perl/${PV}/FileCache.pm \
238 ${PKGD}${libdir}/perl/config.sh \
239 ${PKGD}${libdir}/perl/${PV}/Config.pm \
240 ${PKGD}${libdir}/perl/${PV}/Config_heavy.pl \
241 ${PKGD}${libdir}/perl/${PV}/CORE/perl.h \
242 ${PKGD}${libdir}/perl/${PV}/CORE/pp.h
243}
244
245PACKAGES = "perl-dbg perl perl-misc perl-dev perl-pod perl-doc perl-lib \
246 perl-module-cpan perl-module-cpanplus perl-module-unicore"
247FILES_${PN} = "${bindir}/perl ${bindir}/perl${PV} \
248 ${libdir}/perl/${PV}/Config.pm \
249 ${libdir}/perl/${PV}/strict.pm \
250 ${libdir}/perl/${PV}/warnings.pm \
251 ${libdir}/perl/${PV}/warnings \
252 ${libdir}/perl/${PV}/vars.pm \
253 "
254RPROVIDES_${PN} += "perl-module-strict perl-module-vars perl-module-config perl-module-warnings \
255 perl-module-warnings-register"
256FILES_${PN}-dev = "${libdir}/perl/${PV}/CORE"
257FILES_${PN}-lib = "${libdir}/libperl.so* \
258 ${libdir}/perl5 \
259 ${libdir}/perl/config.sh \
260 ${libdir}/perl/${PV}/Config_heavy.pl \
261 ${libdir}/perl/${PV}/Config_heavy-target.pl"
262FILES_${PN}-pod = "${libdir}/perl/${PV}/pod \
263 ${libdir}/perl/${PV}/*.pod \
264 ${libdir}/perl/${PV}/*/*.pod \
265 ${libdir}/perl/${PV}/*/*/*.pod "
266FILES_perl-misc = "${bindir}/*"
267FILES_${PN}-dbg += "${libdir}/perl/${PV}/auto/*/.debug \
268 ${libdir}/perl/${PV}/auto/*/*/.debug \
269 ${libdir}/perl/${PV}/auto/*/*/*/.debug \
270 ${libdir}/perl/${PV}/CORE/.debug \
271 ${libdir}/perl/${PV}/*/.debug \
272 ${libdir}/perl/${PV}/*/*/.debug \
273 ${libdir}/perl/${PV}/*/*/*/.debug "
274FILES_${PN}-doc = "${libdir}/perl/${PV}/*/*.txt \
275 ${libdir}/perl/${PV}/*/*/*.txt \
276 ${libdir}/perl/${PV}/B/assemble \
277 ${libdir}/perl/${PV}/B/cc_harness \
278 ${libdir}/perl/${PV}/B/disassemble \
279 ${libdir}/perl/${PV}/B/makeliblinks \
280 ${libdir}/perl/${PV}/CGI/eg \
281 ${libdir}/perl/${PV}/CPAN/PAUSE2003.pub \
282 ${libdir}/perl/${PV}/CPAN/SIGNATURE \
283 ${libdir}/perl/${PV}/CPANPLUS/Shell/Default/Plugins/HOWTO.pod \
284 ${libdir}/perl/${PV}/Encode/encode.h \
285 ${libdir}/perl/${PV}/ExtUtils/MANIFEST.SKIP \
286 ${libdir}/perl/${PV}/ExtUtils/NOTES \
287 ${libdir}/perl/${PV}/ExtUtils/PATCHING \
288 ${libdir}/perl/${PV}/ExtUtils/typemap \
289 ${libdir}/perl/${PV}/ExtUtils/xsubpp \
290 ${libdir}/perl/${PV}/ExtUtils/Changes_EU-Install \
291 ${libdir}/perl/${PV}/Net/*.eg \
292 ${libdir}/perl/${PV}/unicore/mktables \
293 ${libdir}/perl/${PV}/unicore/mktables.lst \
294 ${libdir}/perl/${PV}/unicore/version "
295
296FILES_perl-module-cpan += "${libdir}/perl/${PV}/CPAN \
297 ${libdir}/perl/${PV}/CPAN.pm"
298FILES_perl-module-cpanplus += "${libdir}/perl/${PV}/CPANPLUS \
299 ${libdir}/perl/${PV}/CPANPLUS.pm"
300FILES_perl-module-unicore += "${libdir}/perl/${PV}/unicore"
301
302# Create a perl-modules package recommending all the other perl
303# packages (actually the non modules packages and not created too)
304ALLOW_EMPTY_perl-modules = "1"
305PACKAGES_append = " perl-modules "
306
307python populate_packages_prepend () {
308 libdir = d.expand('${libdir}/perl/${PV}')
309 do_split_packages(d, libdir, 'auto/(.*)/[^/]*\.(so|ld|ix|al)', 'perl-module-%s', 'perl module %s', recursive=True, match_path=True, prepend=False)
310 do_split_packages(d, libdir, 'Module/([^\/]*)\.pm', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
311 do_split_packages(d, libdir, 'Module/([^\/]*)/.*', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
312 do_split_packages(d, libdir, '(^(?!(CPAN\/|CPANPLUS\/|Module\/|unicore\/|auto\/)[^\/]).*)\.(pm|pl|e2x)', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
313 d.setVar("RRECOMMENDS_${PN}-modules", d.getVar('PACKAGES', True).replace('${PN}-modules ', '').replace('${PN}-dbg ', '').replace('${PN}-misc ', '').replace('${PN}-dev ', '').replace('${PN}-pod ', '').replace('${PN}-doc ', ''))
314}
315
316PACKAGES_DYNAMIC += "^perl-module-.*"
317PACKAGES_DYNAMIC_class-nativesdk += "^nativesdk-perl-module-.*"
318
319RPROVIDES_perl-lib = "perl-lib"
320
321require perl-rdepends_${PV}.inc
322require perl-rprovides.inc
323require perl-rprovides_${PV}.inc
324include perl-tests.inc
325
326SSTATE_SCAN_FILES += "*.pm *.pod *.h *.pl *.sh"
327
328BBCLASSEXTEND = "nativesdk"