summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl-native_5.14.3.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-07-01 15:51:53 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-08 11:20:12 +0100
commite73deac6dc7861c64ced49d2a35f781d655db79a (patch)
treedf7352dd791d9714ef62d4a6a87b64e2a90903e2 /meta/recipes-devtools/perl/perl-native_5.14.3.bb
parent93d77b6ca83e55f3ecbc09f5502d8ae928f2bd91 (diff)
downloadpoky-e73deac6dc7861c64ced49d2a35f781d655db79a.tar.gz
perl, perl-native, perl-ptest: upgrade from 5.14.3 to 5.20.0
Changed: - The Copying has no change, except the company address. - pick patches from debian http://ftp.de.debian.org/debian/pool/main/p/perl/perl_5.20.0-1.debian.tar.xz - Not used by oe: deprecate-with-apt.diff patchlevel.diff fakeroot.diff - Create/Update perl-rdepends_${PV}.inc by the hardcode script; - Update config.sh by: 1) Copy the Perl 5.20.0 source code onto your TARGET machine linux qemuarm 3.14.5-yocto-standard from OE-Core rev: f506d0660c9949485268a92724ac770b5457b0ca 2) Execute sh Configure as normal and configure as required, do not "make"; 3) Compare with the old config.sh files, and update; - perl-ptest.inc 1) Copy the souce code to ptest since almost 112 test cases failed with the reason that no souce code found; 2) Add two patches to fix test case issue; - perl-native Reference perl (5.20.0-1) in debian to update perl shared library headers https://packages.debian.org/experimental/i386/perl/filelist Obsolete: - 09_fix_installperl.patch The dead code was removed from installperl http://perl5.git.perl.org/perl.git/commit/236818e0b9d9fe874831086b4d0b94dc6f245dfd - perl-build-in-t-dir.patch The upstream has fix it. The issue description: Perl cannot cross build in a path containing a directory that has the name of "t". As an example, you can make the perl build fail with "mkdir -p /tmp/build/t", go to the directory, unpack the sources, configure and cross build. - 0001-Fix-misparsing-of-maketext-strings.patch as they are part of the upstream code now: http://perl5.git.perl.org/perl.git/commit/1735f6f53ca19f99c6e9e39496c486af323ba6a8 - 0001-Prevent-premature-hsplit-calls-and-only-trigger-REHA.patch the hash function changed: http://perl5.git.perl.org/perl.git/commit/7dc8663964c66a698d31bbdc8e8abed69bddeec3 (From OE-Core rev: c7ac82415efc42ff7a93c6df163f88f2dde00d26) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl-native_5.14.3.bb')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.14.3.bb124
1 files changed, 0 insertions, 124 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.14.3.bb b/meta/recipes-devtools/perl/perl-native_5.14.3.bb
deleted file mode 100644
index c38be41d49..0000000000
--- a/meta/recipes-devtools/perl/perl-native_5.14.3.bb
+++ /dev/null
@@ -1,124 +0,0 @@
1SUMMARY = "Perl scripting language"
2HOMEPAGE = "http://www.perl.org/"
3SECTION = "libs"
4LICENSE = "Artistic-1.0 | GPL-1.0"
5
6LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
7 file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
8
9# 5.10.1 has Module::Build built-in
10PROVIDES += "libmodule-build-perl-native"
11
12SRC_URI = "http://www.cpan.org/src/5.0/perl-${PV}.tar.gz \
13 file://Configure-multilib.patch \
14 file://perl-configpm-switch.patch \
15 file://native-nopacklist.patch \
16 file://native-perlinc.patch \
17 file://MM_Unix.pm.patch \
18 file://debian/errno_ver.diff \
19 file://dynaloaderhack.patch \
20 file://perl-build-in-t-dir.patch \
21 file://perl-5.14.3-fix-CVE-2010-4777.patch "
22
23SRC_URI[md5sum] = "f6a3d878c688d111b495c87db56c5be5"
24SRC_URI[sha256sum] = "03638a4f01bc26b81231233671524b4163849a3a9ea5cc2397293080c4ea339f"
25
26S = "${WORKDIR}/perl-${PV}"
27
28inherit native
29
30NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
31
32export LD="${CCLD}"
33
34do_configure () {
35 ./Configure \
36 -Dcc="${CC}" \
37 -Dcflags="${CFLAGS}" \
38 -Dldflags="${LDFLAGS}" \
39 -Dcf_by="Open Embedded" \
40 -Dprefix=${prefix} \
41 -Dvendorprefix=${prefix} \
42 -Dvendorprefix=${prefix} \
43 -Dsiteprefix=${prefix} \
44 \
45 -Dbin=${STAGING_BINDIR}/${PN} \
46 -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \
47 -Darchlib=${STAGING_LIBDIR}/perl/${PV} \
48 -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \
49 -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \
50 -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \
51 -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \
52 \
53 -Duseshrplib \
54 -Dusethreads \
55 -Duseithreads \
56 -Duselargefiles \
57 -Dnoextensions=ODBM_File \
58 -Ud_dosuid \
59 -Ui_db \
60 -Ui_ndbm \
61 -Ui_gdbm \
62 -Di_shadow \
63 -Di_syslog \
64 -Duseperlio \
65 -Dman3ext=3pm \
66 -Dsed=/bin/sed \
67 -Uafs \
68 -Ud_csh \
69 -Uusesfio \
70 -Uusenm -des
71}
72
73do_install () {
74 oe_runmake 'DESTDIR=${D}' install
75
76 # We need a hostperl link for building perl
77 ln -sf perl${PV} ${D}${bindir}/hostperl
78
79 ln -sf perl ${D}${libdir}/perl5
80
81 install -d ${D}${libdir}/perl/${PV}/CORE \
82 ${D}${datadir}/perl/${PV}/ExtUtils
83
84 # Save native config
85 install config.sh ${D}${libdir}/perl
86 install lib/Config.pm ${D}${libdir}/perl/${PV}/
87 install lib/ExtUtils/typemap ${D}${libdir}/perl/${PV}/ExtUtils/
88
89 # perl shared library headers
90 for i in av.h bitcount.h config.h cop.h cv.h dosish.h embed.h embedvar.h \
91 EXTERN.h fakesdio.h fakethr.h form.h gv.h handy.h hv.h INTERN.h \
92 intrpvar.h iperlsys.h keywords.h l1_char_class_tab.h malloc_ctl.h \
93 metaconfig.h mg.h mydtrace.h nostdio.h opcode.h op.h opnames.h \
94 op_reg_common.h overload.h pad.h parser.h patchlevel.h perlapi.h \
95 perl.h perlio.h perliol.h perlsdio.h perlsfio.h perlvars.h \
96 perly.h pp.h pp_proto.h proto.h reentr.h regcharclass.h regcomp.h \
97 regexp.h regnodes.h scope.h sv.h thread.h time64_config.h \
98 time64.h uconfig.h unixish.h utf8.h utfebcdic.h util.h \
99 uudmap.h warnings.h XSUB.h
100 do
101 install $i ${D}${libdir}/perl/${PV}/CORE
102 done
103
104 create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
105 create_wrapper ${D}${bindir}/perl${PV} PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
106}
107
108SYSROOT_PREPROCESS_FUNCS += "perl_sysroot_create_wrapper"
109
110perl_sysroot_create_wrapper () {
111 mkdir -p ${SYSROOT_DESTDIR}${bindir}
112 # Create a wrapper that /usr/bin/env perl will use to get perl-native.
113 # This MUST live in the normal bindir.
114 cat > ${SYSROOT_DESTDIR}${bindir}/../nativeperl << EOF
115#!/bin/sh
116realpath=\`readlink -fn \$0\`
117exec \`dirname \$realpath\`/perl-native/perl "\$@"
118EOF
119 chmod 0755 ${SYSROOT_DESTDIR}${bindir}/../nativeperl
120 cat ${SYSROOT_DESTDIR}${bindir}/../nativeperl
121}
122
123# Fix the path in sstate
124SSTATE_SCAN_FILES += "*.pm *.pod *.h *.pl *.sh"