summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl-native_5.12.3.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-10-19 14:53:17 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-24 17:27:14 +0100
commit5f8f114e4cc29e96942f96ef7dec6d25e18b6d4f (patch)
tree5b7867dec533d001ce29d8bf7b4869299cea254f /meta/recipes-devtools/perl/perl-native_5.12.3.bb
parent53f7342562a66d1b14ecee234aa76be07951dedc (diff)
downloadpoky-5f8f114e4cc29e96942f96ef7dec6d25e18b6d4f.tar.gz
perl: upgrade from 5.12.3 to 5.14.2
parallel build fix patches are not needed as they are upstream now. Got a new set of debian patch set for 5.14.2 perl-rpdepends: fix the autogenerated rdepends mistakes take out some mdoules which are not going to be built. [Saul Wold: Remove debug] (From OE-Core rev: 8dc5f118832a4aca906239ffed82f72497c37f8e) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl-native_5.12.3.bb')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.12.3.bb120
1 files changed, 0 insertions, 120 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.12.3.bb b/meta/recipes-devtools/perl/perl-native_5.12.3.bb
deleted file mode 100644
index a8e2346606..0000000000
--- a/meta/recipes-devtools/perl/perl-native_5.12.3.bb
+++ /dev/null
@@ -1,120 +0,0 @@
1DESCRIPTION = "Perl is a popular scripting language."
2HOMEPAGE = "http://www.perl.org/"
3SECTION = "libs"
4LICENSE = "Artistic|GPL"
5LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
6 file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
7PR = "r5"
8
9LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
10 file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
11
12SRC_URI = "http://www.cpan.org/src/5.0/perl-${PV}.tar.gz \
13 file://Configure-multilib.patch \
14 file://perl-configpm-switch.patch \
15 file://parallel_build_fix_1.patch \
16 file://parallel_build_fix_2.patch \
17 file://parallel_build_fix_3.patch \
18 file://parallel_build_fix_4.patch \
19 file://parallel_build_fix_5.patch \
20 file://parallel_build_fix_6.patch \
21 file://native-nopacklist.patch \
22 file://native-perlinc.patch \
23 file://MM_Unix.pm.patch"
24
25SRC_URI[md5sum] = "29975a69dce54e47fcd6331c085c6c99"
26SRC_URI[sha256sum] = "5678bfd5c2cd59253a26171bf3e681235433b00c730eea8a8046e1b225c11d2f"
27
28S = "${WORKDIR}/perl-${PV}"
29
30inherit native
31
32NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
33
34export LD="${CCLD}"
35
36do_configure () {
37 ./Configure \
38 -Dcc="${CC}" \
39 -Dcflags="${CFLAGS}" \
40 -Dldflags="${LDFLAGS}" \
41 -Dcf_by="Open Embedded" \
42 -Dprefix=${prefix} \
43 -Dvendorprefix=${prefix} \
44 -Dvendorprefix=${prefix} \
45 -Dsiteprefix=${prefix} \
46 \
47 -Dbin=${STAGING_BINDIR}/${PN} \
48 -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \
49 -Darchlib=${STAGING_LIBDIR}/perl/${PV} \
50 -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \
51 -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \
52 -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \
53 -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \
54 \
55 -Duseshrplib \
56 -Dusethreads \
57 -Duseithreads \
58 -Duselargefiles \
59 -Dnoextensions=ODBM_File \
60 -Ud_dosuid \
61 -Ui_db \
62 -Ui_ndbm \
63 -Ui_gdbm \
64 -Di_shadow \
65 -Di_syslog \
66 -Duseperlio \
67 -Dman3ext=3pm \
68 -Uafs \
69 -Ud_csh \
70 -Uusesfio \
71 -Uusenm -des
72}
73
74do_install () {
75 oe_runmake 'DESTDIR=${D}' install
76
77 # We need a hostperl link for building perl
78 ln -sf perl${PV} ${D}${bindir}/hostperl
79
80 ln -sf perl ${D}${libdir}/perl5
81
82 install -d ${D}${libdir}/perl/${PV}/CORE \
83 ${D}${datadir}/perl/${PV}/ExtUtils
84
85 # Save native config
86 install config.sh ${D}${libdir}/perl
87 install lib/Config.pm ${D}${libdir}/perl/${PV}/
88 install lib/ExtUtils/typemap ${D}${libdir}/perl/${PV}/ExtUtils/
89
90 # perl shared library headers
91 for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \
92 uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \
93 perliol.h pp_proto.h regnodes.h unixish.h config.h EXTERN.h \
94 hv.h malloc_ctl.h pad.h perlsdio.h proto.h scope.h utf8.h \
95 cop.h fakesdio.h INTERN.h mg.h patchlevel.h perlsfio.h \
96 reentr.h sv.h utfebcdic.h cv.h fakethr.h intrpvar.h \
97 nostdio.h perlapi.h perlvars.h util.h \
98 dosish.h form.h iperlsys.h opcode.h perl.h perly.h regcomp.h \
99 thread.h warnings.h; do
100 install $i ${D}${libdir}/perl/${PV}/CORE
101 done
102
103 create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
104 create_wrapper ${D}${bindir}/perl${PV} PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/'
105}
106
107SYSROOT_PREPROCESS_FUNCS += "perl_sysroot_create_wrapper"
108
109perl_sysroot_create_wrapper () {
110 mkdir -p ${SYSROOT_DESTDIR}${bindir}
111 # Create a wrapper that /usr/bin/env perl will use to get perl-native.
112 # This MUST live in the normal bindir.
113 cat > ${SYSROOT_DESTDIR}${bindir}/../nativeperl << EOF
114#!/bin/sh
115realpath=\`readlink -fn \$0\`
116exec \`dirname \$realpath\`/perl-native/perl "\$@"
117EOF
118 chmod 0755 ${SYSROOT_DESTDIR}${bindir}/../nativeperl
119 cat ${SYSROOT_DESTDIR}${bindir}/../nativeperl
120}