summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl-5.12.2/debian/fixes/concat-stack-corruption.diff
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-12-22 09:26:07 -0800
committerSaul Wold <sgw@linux.intel.com>2011-01-12 00:55:48 -0800
commitf57e9daf74d5fbab6c9a3f5e60e1320a0bf0642d (patch)
treef6b24ea8f39fd6c83a161f91117641a851c4a9c6 /meta/recipes-devtools/perl/perl-5.12.2/debian/fixes/concat-stack-corruption.diff
parentfde91acaf7849d80a2b9c908398bee2c3452004e (diff)
downloadpoky-f57e9daf74d5fbab6c9a3f5e60e1320a0bf0642d.tar.gz
perl, perl-native: upgrade from 5.8.8 to 5.12.2
Deleted these patches as they are part of the upstream code now. deleted: files/perl-5.8.8-gcc-4.2.patch deleted: perl-5.12.2/makedepend-dash.patch deleted: perl-5.12.2/native-no-gdbminc.patch deleted: perl-5.12.2/54_debian_perldoc-r.patch And rebased these patches to the newer source code modified: files/letgcc-find-errno.patch modified: perl-5.12.2/Makefile.patch modified: perl-5.12.2/asm-pageh-fix.patch modified: perl-5.12.2/native-nopacklist.patch modified: perl-5.12.2/native-perlinc.patch modified: perl-5.12.2/Makefile.SH.patch modified: perl-5.12.2/installperl.patch modified: perl-5.12.2/perl-dynloader.patch modified: perl-5.12.2/09_fix_installperl.patch get patches from debian perl ver 5.12.2-2 the fakeroot.diff patch from debian is conflicting with our Makefile.SH.patch, hence disabling the fakeroot patch use newly created config files Created with current milestone branch on qemu machines modified: config.sh modified: config.sh-32 modified: config.sh-64 get some changes from oe's perl 5.10.1 recipe fix the Makefile.SH.patch use miniperl instead of perl import a OE 5.10.1 patch: uudmap_cross fix install issues add /usr in the destdir, so that perl gets installed in /usr/bin/perl and not in /bin/perl link /usr/lib/perl to /usr/lib/perl5 so that operations with /usr/lib/perl path in them keep on working. Fix/Improve perl packaging avoid perl-module-module-* kind of packages recreate perl-rdepends_5.12.2.inc file with new set of packages import from oe perl-rprovide_5.12.2.inc combine all unicore perl scripts in one package simplify perl-lib reduce no of perl recipe packages greatly. Add zlib to depedancy fix buildtime host contamination This also fixes [BUGID #384] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/perl-5.12.2/debian/fixes/concat-stack-corruption.diff')
-rw-r--r--meta/recipes-devtools/perl/perl-5.12.2/debian/fixes/concat-stack-corruption.diff37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-5.12.2/debian/fixes/concat-stack-corruption.diff b/meta/recipes-devtools/perl/perl-5.12.2/debian/fixes/concat-stack-corruption.diff
new file mode 100644
index 0000000000..6feb8401fe
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl-5.12.2/debian/fixes/concat-stack-corruption.diff
@@ -0,0 +1,37 @@
1From: Niko Tyni <ntyni@debian.org>
2Subject: Fix stack pointer corruption in pp_concat() with 'use encoding'
3Bug-Debian: http://bugs.debian.org/596105
4Bug: http://rt.perl.org/rt3/Ticket/Display.html?id=78674
5Origin: upstream, http://perl5.git.perl.org/perl.git/commit/e3393f51d48d8b790e26324eb0336fac9689fa46
6
7If the stack is reallocated during pp_concat() and 'use encoding' in
8effect, the stack pointer gets corrupted, causing memory allocation bugs
9and the like.
10
11---
12 pp_hot.c | 3 +++
13 1 files changed, 3 insertions(+), 0 deletions(-)
14
15diff --git a/pp_hot.c b/pp_hot.c
16index 3371e88..e9cccf3 100644
17--- a/pp_hot.c
18+++ b/pp_hot.c
19@@ -271,6 +271,8 @@ PP(pp_concat)
20 rbyte = !DO_UTF8(right);
21 }
22 if (lbyte != rbyte) {
23+ /* sv_utf8_upgrade_nomg() may reallocate the stack */
24+ PUTBACK;
25 if (lbyte)
26 sv_utf8_upgrade_nomg(TARG);
27 else {
28@@ -279,6 +281,7 @@ PP(pp_concat)
29 sv_utf8_upgrade_nomg(right);
30 rpv = SvPV_const(right, rlen);
31 }
32+ SPAGAIN;
33 }
34 sv_catpvn_nomg(TARG, rpv, rlen);
35
36--
37tg: (c823880..) fixes/concat-stack-corruption (depends on: upstream)