summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/libxml-parser-perl_2.46.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-28 23:28:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-02 15:44:10 +0100
commitbb6ddc3691ab04162ec5fd69a2d5e7876713fd15 (patch)
tree76e376b01253c3aace1a98a5021bcaad3c92e861 /meta/recipes-devtools/perl/libxml-parser-perl_2.46.bb
parentfcc456ee4b8f619134abb4649db53c638074082c (diff)
downloadpoky-bb6ddc3691ab04162ec5fd69a2d5e7876713fd15.tar.gz
Convert to new override syntax
This is the result of automated script conversion: scripts/contrib/convert-overrides.py <oe-core directory> converting the metadata to use ":" as the override character instead of "_". (From OE-Core rev: 42344347be29f0997cc2f7636d9603b1fe1875ae) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/libxml-parser-perl_2.46.bb')
-rw-r--r--meta/recipes-devtools/perl/libxml-parser-perl_2.46.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/perl/libxml-parser-perl_2.46.bb b/meta/recipes-devtools/perl/libxml-parser-perl_2.46.bb
index bc154bbdc5..3b9206e984 100644
--- a/meta/recipes-devtools/perl/libxml-parser-perl_2.46.bb
+++ b/meta/recipes-devtools/perl/libxml-parser-perl_2.46.bb
@@ -21,13 +21,13 @@ inherit cpan ptest-perl
21 21
22# fix up sub MakeMaker project as arguments don't get propagated though 22# fix up sub MakeMaker project as arguments don't get propagated though
23# see https://rt.cpan.org/Public/Bug/Display.html?id=28632 23# see https://rt.cpan.org/Public/Bug/Display.html?id=28632
24do_configure_append_class-target() { 24do_configure:append:class-target() {
25 sed -E \ 25 sed -E \
26 -e 's:-L${STAGING_LIBDIR}::g' -e 's:-I${STAGING_INCDIR}::g' \ 26 -e 's:-L${STAGING_LIBDIR}::g' -e 's:-I${STAGING_INCDIR}::g' \
27 -i Makefile Expat/Makefile 27 -i Makefile Expat/Makefile
28} 28}
29 29
30do_configure_append() { 30do_configure:append() {
31 sed -e 's:--sysroot=.*\(\s\|$\):--sysroot=${STAGING_DIR_TARGET} :g' \ 31 sed -e 's:--sysroot=.*\(\s\|$\):--sysroot=${STAGING_DIR_TARGET} :g' \
32 -i Makefile Expat/Makefile 32 -i Makefile Expat/Makefile
33 sed 's:^FULL_AR = .*:FULL_AR = ${AR}:g' -i Expat/Makefile 33 sed 's:^FULL_AR = .*:FULL_AR = ${AR}:g' -i Expat/Makefile
@@ -40,7 +40,7 @@ do_compile() {
40 cpan_do_compile 40 cpan_do_compile
41} 41}
42 42
43do_compile_class-native() { 43do_compile:class-native() {
44 cpan_do_compile 44 cpan_do_compile
45} 45}
46 46
@@ -53,6 +53,6 @@ do_install_ptest() {
53 chown -R root:root ${D}${PTEST_PATH}/samples 53 chown -R root:root ${D}${PTEST_PATH}/samples
54} 54}
55 55
56RDEPENDS_${PN}-ptest += "perl-module-filehandle perl-module-if perl-module-test perl-module-test-more" 56RDEPENDS:${PN}-ptest += "perl-module-filehandle perl-module-if perl-module-test perl-module-test-more"
57 57
58BBCLASSEXTEND="native nativesdk" 58BBCLASSEXTEND="native nativesdk"