summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liburi-perl_1.72.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2017-08-15 17:30:13 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-17 00:21:15 +0100
commit61135bcde784b843c656d0d9f644296ce51b55bc (patch)
tree9b545442cb65fa26fa8d790bdce806ef7e47ae6f /meta/recipes-devtools/perl/liburi-perl_1.72.bb
parentc89ed0fd756ae58fe52a15abf31a842b30881995 (diff)
downloadpoky-61135bcde784b843c656d0d9f644296ce51b55bc.tar.gz
liburi-perl: Upgrade to 1.72
(From OE-Core rev: a63c2e450da2627a831483ccaded4ef832848f5d) Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/liburi-perl_1.72.bb')
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.72.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.72.bb b/meta/recipes-devtools/perl/liburi-perl_1.72.bb
new file mode 100644
index 0000000000..a399c10b5c
--- /dev/null
+++ b/meta/recipes-devtools/perl/liburi-perl_1.72.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Perl module to manipulate and access URI strings"
2DESCRIPTION = "This package contains the URI.pm module with friends. \
3The module implements the URI class. URI objects can be used to access \
4and manipulate the various components that make up these strings."
5
6HOMEPAGE = "http://search.cpan.org/dist/URI/"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=c453e94fae672800f83bc1bd7a38b53f"
11
12DEPENDS += "perl"
13
14SRC_URI = "http://www.cpan.org/authors/id/E/ET/ETHER/URI-${PV}.tar.gz"
15
16SRC_URI[md5sum] = "cd56d81ed429efaa97e7f3ff08851b48"
17SRC_URI[sha256sum] = "35f14431d4b300de4be1163b0b5332de2d7fbda4f05ff1ed198a8e9330d40a32"
18
19S = "${WORKDIR}/URI-${PV}"
20
21EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
22
23inherit cpan
24
25do_compile() {
26 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
27 cpan_do_compile
28}
29
30BBCLASSEXTEND = "native"