summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liburi-perl_1.58.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-04-07 09:13:56 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-08 06:14:59 -0700
commit78508384860137caa8278e6793f310e24f38cc8f (patch)
treefdb8fd84804832632d884de9975618fa561b2042 /meta/recipes-devtools/perl/liburi-perl_1.58.bb
parent4344df2e25309cbf059ac6e04f17312e88d90fc3 (diff)
downloadpoky-78508384860137caa8278e6793f310e24f38cc8f.tar.gz
liburi-perl: update to 1.58
(From OE-Core rev: 26b5332372513bfd70abd8d8e5fe0a5880eb0791) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/liburi-perl_1.58.bb')
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.58.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.58.bb b/meta/recipes-devtools/perl/liburi-perl_1.58.bb
new file mode 100644
index 0000000000..76a1231388
--- /dev/null
+++ b/meta/recipes-devtools/perl/liburi-perl_1.58.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "This package contains the URI.pm module with friends. \
2The module implements the URI class. URI objects can be used to access \
3and manipulate the various components that make up these strings."
4
5SECTION = "libs"
6LICENSE = "Artistic | GPLv1+"
7PR = "r0"
8
9LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=6c33ae5c87fd1c4897714e122dd9c23d"
10
11DEPENDS += "perl"
12
13SRC_URI = "http://www.cpan.org/authors/id/G/GA/GAAS/URI-${PV}.tar.gz"
14
15S = "${WORKDIR}/URI-${PV}"
16
17EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
18
19inherit cpan
20
21do_compile() {
22 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
23 cpan_do_compile
24}
25