summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/libtest-needs-perl_0.002010.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2023-02-03 09:50:22 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-02-04 17:02:09 +0000
commitd663b2b57b60a622dd2a2c2e469c9bbe7babe136 (patch)
treee63bbd0609830aa27e775e3cb0bc0c6a00c3629a /meta/recipes-devtools/perl/libtest-needs-perl_0.002010.bb
parent063bdffc04714c7ed4bdba2aa93a19dd94f256a9 (diff)
downloadpoky-d663b2b57b60a622dd2a2c2e469c9bbe7babe136.tar.gz
libtest-needs-perl: upgrade 0.002009 -> 0.002010
0.002010 - 2023-01-22 - split main test into three separate scripts - avoid outputting multiple plans if used with no_plan (From OE-Core rev: 25cbcfe53fc921d856586c76b563016b8756374e) Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/libtest-needs-perl_0.002010.bb')
-rw-r--r--meta/recipes-devtools/perl/libtest-needs-perl_0.002010.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libtest-needs-perl_0.002010.bb b/meta/recipes-devtools/perl/libtest-needs-perl_0.002010.bb
new file mode 100644
index 0000000000..79a06170e0
--- /dev/null
+++ b/meta/recipes-devtools/perl/libtest-needs-perl_0.002010.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Skip tests when modules not available"
2DESCRIPTION = "Skip test scripts if modules are not available. \
3The requested modules will be loaded, and optionally have their versions \
4checked. If the module is missing, the test script will be skipped. Modules \
5that are found but fail to compile will exit with an error rather than skip."
6
7HOMEPAGE = "https://metacpan.org/release/Test-Needs"
8SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
10
11CPAN_NAME = "Test-Needs"
12CPAN_AUTHOR = "HAARG"
13
14LIC_FILES_CHKSUM = "file://README;md5=3f3ccd21a0a48aa313db212cc3b1bc09;beginline=88;endline=89"
15
16DEPENDS += "perl"
17
18SRC_URI = "https://cpan.metacpan.org/authors/id/H/HA/${CPAN_AUTHOR}/${CPAN_NAME}-${PV}.tar.gz"
19
20SRC_URI[sha256sum] = "923ffdc78fcba96609753e4bae26b0ba0186893de4a63cd5236e012c7c90e208"
21
22S = "${WORKDIR}/${CPAN_NAME}-${PV}"
23
24inherit cpan ptest-perl
25
26RDEPENDS:${PN}-ptest += "perl-module-test-more perl-module-ipc-open3 perl-module-lib perl-module-version"
27
28BBCLASSEXTEND = "native"