summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/libtest-fatal-perl_0.017.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-01-04 12:05:11 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-06 12:03:47 +0000
commit26b062b25da2fff27fdd4cc34d6c3adbd485cffc (patch)
tree6cb93e7170b0da823567fec18c99d8f835c5c554 /meta/recipes-devtools/perl/libtest-fatal-perl_0.017.bb
parent2d6b08eba3048a3a82a627036edd06cf26df12fb (diff)
downloadpoky-26b062b25da2fff27fdd4cc34d6c3adbd485cffc.tar.gz
libtest-fatal-perl: upgrade 0.016 -> 0.017
License-Update: formatting (From OE-Core rev: 60663d6151e40ad9c6cc453c3138d0b7cec5a48d) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/libtest-fatal-perl_0.017.bb')
-rw-r--r--meta/recipes-devtools/perl/libtest-fatal-perl_0.017.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libtest-fatal-perl_0.017.bb b/meta/recipes-devtools/perl/libtest-fatal-perl_0.017.bb
new file mode 100644
index 0000000000..1c3a7e5136
--- /dev/null
+++ b/meta/recipes-devtools/perl/libtest-fatal-perl_0.017.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Incredibly simple helpers for testing code with exceptions"
2DESCRIPTION = "Test::Fatal is an alternative to the popular Test::Exception.\
3It does much less, but should allow greater flexibility in testing \
4exception-throwing code with about the same amount of typing."
5HOMEPAGE = "https://github.com/rjbs/Test-Fatal"
6BUGTRACKER = "https://github.com/rjbs/Test-Fatal/issues"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=b5c851290cab1dda12fcfb0e9ec43639"
11
12SRC_URI = "${CPAN_MIRROR}/authors/id/R/RJ/RJBS/Test-Fatal-${PV}.tar.gz"
13
14SRC_URI[sha256sum] = "37dfffdafb84b762efe96b02fb2aa41f37026c73e6b83590db76229697f3c4a6"
15
16S = "${WORKDIR}/Test-Fatal-${PV}"
17
18inherit cpan ptest-perl
19
20RDEPENDS:${PN} += "\
21 libtry-tiny-perl \
22 perl-module-carp \
23 perl-module-exporter \
24 perl-module-test-builder \
25"
26
27RDEPENDS:${PN}-ptest += "\
28 perl-module-extutils-makemaker \
29 perl-module-extutils-mm-unix \
30 perl-module-file-spec \
31 perl-module-overload \
32 perl-module-test-builder-tester \
33 perl-module-test-more \
34"
35
36BBCLASSEXTEND = "native nativesdk"