summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/libtest-fatal-perl_0.016.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-11-18 09:52:05 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-11-22 12:26:45 +0000
commit9b331dbb58704911de577aa1118f94a5116f5020 (patch)
treeddafff8689c3c2c5aede4843b9e74b2062d985ab /meta/recipes-devtools/perl/libtest-fatal-perl_0.016.bb
parente7acf25c74b71b852512def4bb4e37c55f291e92 (diff)
downloadpoky-9b331dbb58704911de577aa1118f94a5116f5020.tar.gz
libtest-fatal-perl: add recipe for 0.016
Test::Fatal - incredibly simple helpers for testing code with exceptions https://metacpan.org/release/RJBS/Test-Fatal-0.016 * Dependency for liburi-perl ptest. * Add self as maintainer * Add to ptest-packages.inc (fast) (From OE-Core rev: 285643275ef0ac04bdc3ce500a79f49629e7ebba) Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/libtest-fatal-perl_0.016.bb')
-rw-r--r--meta/recipes-devtools/perl/libtest-fatal-perl_0.016.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libtest-fatal-perl_0.016.bb b/meta/recipes-devtools/perl/libtest-fatal-perl_0.016.bb
new file mode 100644
index 0000000000..6d36c94eeb
--- /dev/null
+++ b/meta/recipes-devtools/perl/libtest-fatal-perl_0.016.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Incredibly simple helpers for testing code with exceptions"
2DESCRIPTION = "Test::Fatal is an alternative to the popular Test::Exception.\
3It does much less, but should allow greater flexibility in testing \
4exception-throwing code with about the same amount of typing."
5HOMEPAGE = "https://github.com/rjbs/Test-Fatal"
6BUGTRACKER = "https://github.com/rjbs/Test-Fatal/issues"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=f7c73bf24be1bc7759bde9c15000db6c"
11
12SRC_URI = "${CPAN_MIRROR}/authors/id/R/RJ/RJBS/Test-Fatal-${PV}.tar.gz"
13
14SRC_URI[sha256sum] = "7283d430f2ba2030b8cd979ae3039d3f1b2ec3dde1a11ca6ae09f992a66f788f"
15
16S = "${WORKDIR}/Test-Fatal-${PV}"
17
18inherit cpan ptest-perl
19
20RDEPENDS:${PN} += "\
21 libtry-tiny-perl \
22 perl-module-carp \
23 perl-module-exporter \
24 perl-module-test-builder \
25"
26
27RDEPENDS:${PN}-ptest += "\
28 perl-module-extutils-makemaker \
29 perl-module-extutils-mm-unix \
30 perl-module-file-spec \
31 perl-module-overload \
32 perl-module-test-builder-tester \
33 perl-module-test-more \
34"
35
36BBCLASSEXTEND = "native nativesdk"