summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liberror-perl_0.17026.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-06-11 22:31:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-15 17:56:24 +0100
commit5b0a32a5a778ebcd01adb8d925f8443b213436dc (patch)
tree695819d05edd4e02fda39ae8fc6554e28d9a3af6 /meta/recipes-devtools/perl/liberror-perl_0.17026.bb
parentf706c89ca1be028679f0e8bc6569b2ddb1a7c235 (diff)
downloadpoky-5b0a32a5a778ebcd01adb8d925f8443b213436dc.tar.gz
liberror-perl: upgrade 0.17025 -> 0.17026
* Upstream release notes: " May 23 2018 <shlomif@shlomifish.org> (Shlomi Fish) Error.pm #0.17026 - Convert to Dist-Zilla. " * Tested on qemux86: all tests pass (From OE-Core rev: 8a5d5a8422239d45aba73595ee2a2120adf93c84) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/liberror-perl_0.17026.bb')
-rw-r--r--meta/recipes-devtools/perl/liberror-perl_0.17026.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liberror-perl_0.17026.bb b/meta/recipes-devtools/perl/liberror-perl_0.17026.bb
new file mode 100644
index 0000000000..6f42b47298
--- /dev/null
+++ b/meta/recipes-devtools/perl/liberror-perl_0.17026.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Error - Error/exception handling in an OO-ish way"
2DESCRIPTION = "The Error package provides two interfaces. Firstly \
3Error provides a procedural interface to exception handling. \
4Secondly Error is a base class for errors/exceptions that can \
5either be thrown, for subsequent catch, or can simply be recorded."
6
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100"
11
12DEPENDS += "perl"
13
14SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz"
15
16SRC_URI[md5sum] = "0dcd94640f617df02b6d6c1e4e92018c"
17SRC_URI[sha256sum] = "37590a962cd73ae03470e1ff16459a6cbc5273fc57626b8981dab9c2433155d9"
18
19S = "${WORKDIR}/Error-${PV}"
20
21inherit cpan ptest-perl
22
23do_compile() {
24 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
25 cpan_do_compile
26}
27
28do_install_prepend() {
29 # test requires "-T" (taint) command line option
30 rm -rf ${B}/t/pod-coverage.t
31}
32
33BBCLASSEXTEND = "native"