summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg_0.4.0.bb
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2018-12-26 17:59:04 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-27 22:52:58 +0000
commit7dfee9b78daa5d25551704f27d0228b2c170fbcc (patch)
treef63d456076d725fd74dba297f6dd32ea8f9e140b /meta/recipes-devtools/opkg/opkg_0.4.0.bb
parentffae6c9e6c3a20ae72b9dcc7b1b2eb4cdb629574 (diff)
downloadpoky-7dfee9b78daa5d25551704f27d0228b2c170fbcc.tar.gz
opkg: upgrade to version 0.4.0
- Drop 0001-remove_maintainer_scripts-use-strict-matching.patch (From OE-Core rev: 74d3b4a199bfeae99dfbe6f23f1c3cb4bf76abff) Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_0.4.0.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.4.0.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.4.0.bb b/meta/recipes-devtools/opkg/opkg_0.4.0.bb
new file mode 100644
index 0000000000..9b7cf3f596
--- /dev/null
+++ b/meta/recipes-devtools/opkg/opkg_0.4.0.bb
@@ -0,0 +1,61 @@
1SUMMARY = "Open Package Manager"
2SUMMARY_libopkg = "Open Package Manager library"
3SECTION = "base"
4HOMEPAGE = "http://code.google.com/p/opkg/"
5BUGTRACKER = "http://code.google.com/p/opkg/issues/list"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://src/opkg.c;beginline=2;endline=21;md5=90435a519c6ea69ef22e4a88bcc52fa0"
9
10DEPENDS = "libarchive"
11
12PE = "1"
13
14SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
15 file://opkg.conf \
16 file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
17"
18
19SRC_URI[md5sum] = "ae51d95fee599bb4dce08453529158f5"
20SRC_URI[sha256sum] = "f6c00515d8a2ad8f6742a8e73830315d1983ed0459cba77c4d656cfc9e7fe6fe"
21
22inherit autotools pkgconfig systemd
23
24target_localstatedir := "${localstatedir}"
25OPKGLIBDIR = "${target_localstatedir}/lib"
26
27PACKAGECONFIG ??= "libsolv"
28
29PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg"
30PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
31PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl"
32PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
33PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256"
34PACKAGECONFIG[pathfinder] = "--enable-pathfinder,--disable-pathfinder,pathfinder"
35PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv"
36
37EXTRA_OECONF_class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}"
38
39do_install_append () {
40 install -d ${D}${sysconfdir}/opkg
41 install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
42 echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf
43
44 # We need to create the lock directory
45 install -d ${D}${OPKGLIBDIR}/opkg
46}
47
48RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive"
49RDEPENDS_${PN}_class-native = ""
50RDEPENDS_${PN}_class-nativesdk = ""
51RREPLACES_${PN} = "opkg-nogpg opkg-collateral"
52RCONFLICTS_${PN} = "opkg-collateral"
53RPROVIDES_${PN} = "opkg-collateral"
54
55PACKAGES =+ "libopkg"
56
57FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/"
58
59BBCLASSEXTEND = "native nativesdk"
60
61CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf"