summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2020-05-07 11:24:32 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-09 18:57:21 +0100
commitd15a8d87b63aed730fe19a500223752a2dbab6b2 (patch)
tree293a713b195cce861a90e3c213da42511da2cf83 /meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
parent86b52473482c878d490557a2958511e70703672c (diff)
downloadpoky-d15a8d87b63aed730fe19a500223752a2dbab6b2.tar.gz
opkg-keyrings: check if opkg-key exists before run postinst
By default, the opkg-key command is not included in pokg package because it is only installed when gpg support is enabled. We'd better check if it exists before run 'opkg-key populate' in pkg_postinst. (From OE-Core rev: 096a03659cdfa99ca2b4b50ff37d6f2001d0bc90) Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb b/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
index a20e316a3d..07e2402545 100644
--- a/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
+++ b/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
@@ -36,5 +36,8 @@ FILES_${PN} = "${datadir}/opkg/keyrings"
36RDEPENDS_${PN} = "opkg" 36RDEPENDS_${PN} = "opkg"
37 37
38pkg_postinst_ontarget_${PN} () { 38pkg_postinst_ontarget_${PN} () {
39opkg-key populate 39 if test -x ${bindir}/opkg-key
40 then
41 ${bindir}/opkg-key populate
42 fi
40} 43}