summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb
diff options
context:
space:
mode:
authorPaul Barker <paul@paulbarker.me.uk>2014-12-19 17:31:16 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-03 14:53:55 +0000
commitd1373d46421443cf5f4c639d8108a0a72cc69744 (patch)
treeafb72171e8983b23ce058cce4948884b7c40ec42 /meta/recipes-devtools/opkg/opkg-config-base_1.0.bb
parentcb6501acb5da3da7acc1463a20e0b8aaa32ec2ce (diff)
downloadpoky-d1373d46421443cf5f4c639d8108a0a72cc69744.tar.gz
opkg-arch-config: Renamed from opkg-config-base
The name 'opkg-arch-config' is much more descriptive. (From OE-Core rev: d0cb4fb3aab1d6041f88fa564e5d745629316ae2) Signed-off-by: Paul Barker <paul@paulbarker.me.uk> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg-config-base_1.0.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg-config-base_1.0.bb30
1 files changed, 0 insertions, 30 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb b/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb
deleted file mode 100644
index acbe1296bf..0000000000
--- a/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1SUMMARY = "Base configuration files for opkg"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4PACKAGE_ARCH = "${MACHINE_ARCH}"
5PR = "r1"
6
7do_compile() {
8 mkdir -p ${S}/${sysconfdir}/opkg/
9
10 archconf=${S}/${sysconfdir}/opkg/arch.conf
11
12 rm -f $archconf
13 ipkgarchs="${ALL_MULTILIB_PACKAGE_ARCHS}"
14 priority=1
15 for arch in $ipkgarchs; do
16 echo "arch $arch $priority" >> $archconf
17 priority=$(expr $priority + 5)
18 done
19}
20
21
22do_install () {
23 install -d ${D}${sysconfdir}/opkg
24 install -m 0644 ${S}/${sysconfdir}/opkg/* ${D}${sysconfdir}/opkg/
25}
26
27FILES_${PN} = "${sysconfdir}/opkg/ "
28
29CONFFILES_${PN} += "${sysconfdir}/opkg/arch.conf"
30