summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2018-02-28 14:36:45 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-04 11:35:40 +0000
commit2a8d728681c321179f9091269e7da10c1b8f3af5 (patch)
treef9df84a5b6f17bd4fcbcbd69e7de9e84cb3111cc /meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb
parent795b4b4563bc33c04c3a28c0acddc8aa57fd683f (diff)
downloadpoky-2a8d728681c321179f9091269e7da10c1b8f3af5.tar.gz
opkg-utils: upgrade to version 0.3.6
0.3.5 -> 0.3.6 Patches: - Add support for tar versions that don't support --sort - Use local time when setting the modication time on the archives (From OE-Core rev: fd551c5ad4c82f295470f278c524d55562a67a28) Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb
new file mode 100644
index 0000000000..081d8d8b7d
--- /dev/null
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb
@@ -0,0 +1,66 @@
1SUMMARY = "Additional utilities for the opkg package manager"
2SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system"
3SECTION = "base"
4HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://opkg.py;beginline=2;endline=18;md5=63ce9e6bcc445181cd9e4baf4b4ccc35"
8PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}"
9
10SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \
11 file://0001-Switch-all-scripts-to-use-Python-3.x.patch \
12 file://0001-Only-use-sort-name-on-versions-of-tar-which-support-.patch \
13 file://0002-opkg-build-Use-local-time-for-build_date-since-opkg-.patch \
14"
15SRC_URI_append_class-native = " file://tar_ignore_error.patch"
16UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/"
17
18
19SRC_URI[md5sum] = "391c1c80aca26961375dd22e1d2d0cbf"
20SRC_URI[sha256sum] = "26b3f4dd1c1ef65f519d4cddfb35ebea41ae8af989aea2699a39783598c33769"
21
22TARGET_CC_ARCH += "${LDFLAGS}"
23
24# For native builds we use the host Python
25PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold"
26PYTHONRDEPS_class-native = ""
27
28PACKAGECONFIG = "python update-alternatives"
29PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}"
30PACKAGECONFIG[update-alternatives] = ",,,"
31
32do_install() {
33 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
34 if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then
35 rm -f "${D}${bindir}/update-alternatives"
36 fi
37
38 if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
39 grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm
40 fi
41}
42
43do_install_append_class-target() {
44 if [ -e "${D}${bindir}/update-alternatives" ]; then
45 sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g'
46 fi
47}
48
49# These are empty and will pull python3-dev into images where it wouldn't
50# have been otherwise, so don't generate them.
51PACKAGES_remove = "${PN}-dev ${PN}-staticdev"
52
53PACKAGES =+ "update-alternatives-opkg"
54FILES_update-alternatives-opkg = "${bindir}/update-alternatives"
55RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth"
56RREPLACES_update-alternatives-opkg = "update-alternatives-cworth"
57RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth"
58
59pkg_postrm_update-alternatives-opkg() {
60 rm -rf $D${nonarch_libdir}/opkg/alternatives
61 rmdir $D${nonarch_libdir}/opkg || true
62}
63
64BBCLASSEXTEND = "native nativesdk"
65
66CLEANBROKEN = "1"