summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opensp/opensp_1.5.bb
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2012-05-07 15:49:14 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-08 14:49:15 +0100
commitcc9b58e7a7886eddd7fdd873941ff06c22a19bc0 (patch)
treefeb439e5b43442587d64271a7794fb677440dd5e /meta/recipes-devtools/opensp/opensp_1.5.bb
parente11c4958865455a31cd255d6f1aab60abb84da59 (diff)
downloadpoky-cc9b58e7a7886eddd7fdd873941ff06c22a19bc0.tar.gz
opensp: upgrade to 1.5.2
Removed all patches, they've been integrated upstream. :) Added --disable-doc-build to prevent creation of docs, which otherwise fails with the following configure error: could not find xmlto; set XMLTO or consider --disable-doc-build Removed configure_prepend step that was deleting the m4/ directory, since some macros needed for the build are defined there, and I've not encountered any problems with keeping them there in my testing. (From OE-Core rev: cbd055917b04bf8fc640eee289e443230de139a2) Signed-off-by: Scott Garman <scott.a.garman@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opensp/opensp_1.5.bb')
-rw-r--r--meta/recipes-devtools/opensp/opensp_1.5.bb59
1 files changed, 0 insertions, 59 deletions
diff --git a/meta/recipes-devtools/opensp/opensp_1.5.bb b/meta/recipes-devtools/opensp/opensp_1.5.bb
deleted file mode 100644
index e225add824..0000000000
--- a/meta/recipes-devtools/opensp/opensp_1.5.bb
+++ /dev/null
@@ -1,59 +0,0 @@
1SUMMARY = "An SGML parser"
2DESCRIPTION = "An SGML parser used by the OpenJade suite of utilities."
3HOMEPAGE = "http://openjade.sourceforge.net"
4SECTION = "libs"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045"
7
8PR = "r2"
9
10# At -Os it encounters calls to some inline functions which are then
11# not found in any other objects with gcc 4.5
12FULL_OPTIMIZATION += "-O2"
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/OpenSP-${PV}.tar.gz \
15 file://m4.patch \
16 file://attributevalue.patch \
17 file://rangmap-fix.patch \
18 file://fix-docdir.patch"
19
20SRC_URI[md5sum] = "87f56e79ae0c20397f4207d61d154303"
21SRC_URI[sha256sum] = "987eeb9460185950e066e5db3b5fa531e53e213742b545288405552a5a7bb704"
22
23S = "${WORKDIR}/OpenSP-${PV}"
24
25inherit autotools gettext
26
27EXTRA_OECONF_virtclass-native = "\
28 --enable-default-catalog=${sysconfdir}/sgml/catalog \
29 --enable-default-search-path=${datadir}/sgml \
30 "
31
32do_configure_prepend () {
33 # Stale m4 macros cause a variety of problems
34 rm -rf ${S}/m4/*
35}
36
37do_install_append() {
38 # Set up symlinks to often-used alternate names. See
39 # http://www.linuxfromscratch.org/blfs/view/stable/pst/opensp.html
40 cd ${D}${libdir}
41 ln -sf libosp.so libsp.so
42
43 cd ${D}${bindir}
44 for util in nsgmls sgmlnorm spam spcat spent sx; do
45 ln -sf o$util $util
46 done
47 ln -sf osx sgml2xml
48}
49
50do_install_append_virtclass-native() {
51 for util in nsgmls sgmlnorm spam spcat spent sx; do
52 create_cmdline_wrapper ${D}/${bindir}/$util \
53 -D ${sysconfdir}/sgml
54 done
55}
56
57FILES_${PN} += "${datadir}/OpenSP/"
58
59BBCLASSEXTEND = "native"