summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-09-30 12:52:25 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-10-28 16:15:19 +0100
commit671780de49f93ec1cc28f5ad2a7eebe211918b85 (patch)
tree42ebe78d73a3f0a0fa49fb83ff1f2e557c9dc505 /meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
parentd95ef2a0aa3116783cd01a905b46fc4920ebae9f (diff)
downloadpoky-671780de49f93ec1cc28f5ad2a7eebe211918b85.tar.gz
Remove the SGML stack
It is not used for anything, and is something of a pain to maintain. (From OE-Core rev: 4814d93646f6b86aaffbd3fca1af29c8c577db5b) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/openjade/openjade-native_1.3.2.bb')
-rw-r--r--meta/recipes-devtools/openjade/openjade-native_1.3.2.bb121
1 files changed, 0 insertions, 121 deletions
diff --git a/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb b/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
deleted file mode 100644
index 8b15b0c7ec..0000000000
--- a/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
+++ /dev/null
@@ -1,121 +0,0 @@
1SUMMARY = "Tools for working with DSSSL stylesheets for SGML and XML documents"
2DESCRIPTION = "OpenJade is a suite of tools for validating, \
3processing, and applying DSSSL (Document Style Semantics and \
4Specification Language) stylesheets to SGML and XML documents."
5HOMEPAGE = "http://openjade.sourceforge.net"
6SECTION = "base"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045"
9
10PR = "r5"
11
12DEPENDS = "opensp-native sgml-common-native"
13RDEPENDS_${PN} = "sgml-common-native"
14
15SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/openjade-${PV}.tar.gz \
16 file://makefile.patch \
17 file://msggen.pl.patch \
18 file://reautoconf.patch \
19 file://user-declared-default-constructor.patch \
20 file://fix-regex.patch \
21 file://no-libtool.patch"
22
23SRC_URI[md5sum] = "7df692e3186109cc00db6825b777201e"
24SRC_URI[sha256sum] = "1d2d7996cc94f9b87d0c51cf0e028070ac177c4123ecbfd7ac1cb8d0b7d322d1"
25
26UPSTREAM_CHECK_URI = "http://openjade.sourceforge.net/download.html"
27
28inherit autotools-brokensep native
29
30# Statically link local libs to avoid gold link issue [YOCTO #2972]
31PACKAGECONFIG ?= "static-only-libs"
32PACKAGECONFIG[static-only-libs] = "--enable-static --disable-shared,--enable-static --enable-shared,,"
33
34EXTRA_OECONF = "--enable-spincludedir=${STAGING_INCDIR}/OpenSP \
35 --enable-splibdir=${STAGING_LIBDIR}"
36
37# We need to set datadir explicitly, but adding it to EXTRA_OECONF
38# results in it being specified twice when configure is run.
39CONFIGUREOPTS := "${@d.getVar('CONFIGUREOPTS', True).replace('--datadir=${datadir}', '--datadir=${STAGING_DATADIR}/sgml/openjade-${PV}')}"
40
41# CONFIGUREOPTS has hard coded paths so we need to ignore it's vardeps
42# there are other bits in there too but they are picked up by other variable
43# dependencies so it all works out
44oe_runconf[vardepsexclude] += "CONFIGUREOPTS"
45
46CFLAGS =+ "-I${S}/include"
47CXXFLAGS += "-fno-tree-dse"
48
49SSTATEPOSTINSTFUNCS += "openjade_sstate_postinst"
50SYSROOT_PREPROCESS_FUNCS += "openjade_sysroot_preprocess"
51
52# configure.in needs to be reloacted to trigger reautoconf
53do_extraunpack () {
54 cp ${S}/config/configure.in ${S}/
55}
56addtask extraunpack after do_patch before do_configure
57
58# We need to do this else the source interdependencies aren't generated and
59# build failures can result (e.g. zero size style/Makefile.dep file)
60do_compile_prepend () {
61 oe_runmake depend
62}
63
64do_install() {
65 # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/openjade.html
66 # for details.
67 install -d ${D}${bindir} ${D}${libdir}
68 if ${@bb.utils.contains('PACKAGECONFIG', 'static-only-libs', 'true', 'false', d)}; then
69 install -m 0755 jade/openjade ${D}${bindir}/openjade
70 oe_libinstall -a -C style libostyle ${D}${libdir}
71 oe_libinstall -a -C spgrove libospgrove ${D}${libdir}
72 oe_libinstall -a -C grove libogrove ${D}${libdir}
73 else
74 install -m 0755 jade/.libs/openjade ${D}${bindir}/openjade
75 oe_libinstall -a -so -C style libostyle ${D}${libdir}
76 oe_libinstall -a -so -C spgrove libospgrove ${D}${libdir}
77 oe_libinstall -a -so -C grove libogrove ${D}${libdir}
78 fi
79 ln -sf openjade ${D}${bindir}/jade
80
81 install -d ${D}${datadir}/sgml/openjade-${PV}
82 install -m 644 dsssl/catalog ${D}${datadir}/sgml/openjade-${PV}
83 install -m 644 dsssl/*.dtd ${D}${datadir}/sgml/openjade-${PV}
84 install -m 644 dsssl/*.dsl ${D}${datadir}/sgml/openjade-${PV}
85 install -m 644 dsssl/*.sgm ${D}${datadir}/sgml/openjade-${PV}
86
87 install -d ${datadir}/sgml/openjade-${PV}
88 install -m 644 dsssl/catalog ${datadir}/sgml/openjade-${PV}/catalog
89
90 install -d ${D}${sysconfdir}/sgml
91 echo "CATALOG ${datadir}/sgml/openjade-${PV}/catalog" > \
92 ${D}${sysconfdir}/sgml/openjade-${PV}.cat
93}
94
95openjade_sstate_postinst() {
96 if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
97 then
98 # Ensure that the catalog file sgml-docbook.cat is properly
99 # updated when the package is installed from sstate cache.
100 ${SYSROOT_DESTDIR}${bindir_crossscripts}/install-catalog-openjade \
101 --add ${sysconfdir}/sgml/sgml-docbook.bak \
102 ${sysconfdir}/sgml/openjade-${PV}.cat
103 ${SYSROOT_DESTDIR}${bindir_crossscripts}/install-catalog-openjade \
104 --add ${sysconfdir}/sgml/sgml-docbook.cat \
105 ${sysconfdir}/sgml/openjade-${PV}.cat
106 cat << EOF > ${SSTATE_INST_POSTRM}
107#!/bin/sh
108# Ensure that the catalog file sgml-docbook.cat is properly
109# updated when the package is removed from sstate cache.
110files="${sysconfdir}/sgml/sgml-docbook.bak ${sysconfdir}/sgml/sgml-docbook.cat"
111for f in \$files; do
112 [ ! -f \$f ] || sed -i '/\/sgml\/openjade-${PV}.cat/d' \$f
113done
114EOF
115 fi
116}
117
118openjade_sysroot_preprocess () {
119 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
120 install -m 755 ${STAGING_BINDIR_NATIVE}/install-catalog ${SYSROOT_DESTDIR}${bindir_crossscripts}/install-catalog-openjade
121}