summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ninja/ninja_1.10.2.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-05-24 16:33:45 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-27 23:50:47 +0100
commitaed63b042964cb6cc9cf4e5281a0fcbba47e19e4 (patch)
tree8f67ab07f8bd19f855cc6fdc442ef5bc376a40c3 /meta/recipes-devtools/ninja/ninja_1.10.2.bb
parentf67210f9edf04651e67fb79647beae55f921fd09 (diff)
downloadpoky-aed63b042964cb6cc9cf4e5281a0fcbba47e19e4.tar.gz
ninja: upgrade 1.10.2 -> 1.11.0
(From OE-Core rev: 466fb2e1ec98b0b8b55be7340764dd02967b6761) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ninja/ninja_1.10.2.bb')
-rw-r--r--meta/recipes-devtools/ninja/ninja_1.10.2.bb31
1 files changed, 0 insertions, 31 deletions
diff --git a/meta/recipes-devtools/ninja/ninja_1.10.2.bb b/meta/recipes-devtools/ninja/ninja_1.10.2.bb
deleted file mode 100644
index 7270321d6e..0000000000
--- a/meta/recipes-devtools/ninja/ninja_1.10.2.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1SUMMARY = "Ninja is a small build system with a focus on speed."
2HOMEPAGE = "https://ninja-build.org/"
3DESCRIPTION = "Ninja is a small build system with a focus on speed. It differs from other build systems in two major respects: it is designed to have its input files generated by a higher-level build system, and it is designed to run builds as fast as possible."
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
6
7DEPENDS = "re2c-native ninja-native"
8
9SRCREV = "e72d1d581c945c158ed68d9bc48911063022a2c6"
10
11SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release;protocol=https"
12UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
13
14S = "${WORKDIR}/git"
15
16do_configure[noexec] = "1"
17
18do_compile:class-native() {
19 python3 ./configure.py --bootstrap
20}
21
22do_compile() {
23 python3 ./configure.py
24 ninja
25}
26
27do_install() {
28 install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja
29}
30
31BBCLASSEXTEND = "native nativesdk"