summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.10.07.bb
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2013-01-08 11:58:12 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-10 23:43:10 +0000
commit1226f29bf0d06ae6cf99fd6b6ee286daa88f3229 (patch)
tree6c8bc77a51f0992cc3c3b85c546cb86b68f53f56 /meta/recipes-devtools/nasm/nasm_2.10.07.bb
parent4550b208be77da2dbae7534aee9cec7f16389854 (diff)
downloadpoky-1226f29bf0d06ae6cf99fd6b6ee286daa88f3229.tar.gz
nasm: updated to 2.10.07
(From OE-Core rev: 1880bcddd2532b22542cc6eccbadf889a1749db9) Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.10.07.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.10.07.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.10.07.bb b/meta/recipes-devtools/nasm/nasm_2.10.07.bb
new file mode 100644
index 0000000000..1c95ed82bc
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.10.07.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "General-purpose x86 assembler"
2SECTION = "devel"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
5COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
6
7PR = "r0"
8
9SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
10SRC_URI[md5sum] = "af1cd6669f5e98148cd5ec42dee90f19"
11SRC_URI[sha256sum] = "c056e2abc83816892e448f9e9e95a3d21e9e096f44341b9d4853f62a443bba82"
12
13inherit autotools
14
15do_configure_prepend () {
16 if [ -f aclocal.m4 ] && [ ! -f acinclude.m4 ]; then
17 mv aclocal.m4 acinclude.m4
18 fi
19}
20
21do_install() {
22 install -d ${D}${bindir}
23 install -d ${D}${mandir}/man1
24
25 oe_runmake 'INSTALLROOT=${D}' install
26}
27
28BBCLASSEXTEND = "native"
29
30DEPENDS = "groff-native"