summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mklibs/mklibs-native_0.1.38.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-devtools/mklibs/mklibs-native_0.1.38.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/mklibs/mklibs-native_0.1.38.bb')
-rw-r--r--meta/recipes-devtools/mklibs/mklibs-native_0.1.38.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/mklibs/mklibs-native_0.1.38.bb b/meta/recipes-devtools/mklibs/mklibs-native_0.1.38.bb
new file mode 100644
index 0000000000..fd04c97b82
--- /dev/null
+++ b/meta/recipes-devtools/mklibs/mklibs-native_0.1.38.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Shared library optimisation tool"
2DESCRIPTION = "mklibs produces cut-down shared libraries that contain only the routines required by a particular set of executables."
3HOMEPAGE = "https://code.launchpad.net/mklibs"
4SECTION = "devel"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://debian/copyright;md5=98d31037b13d896e33890738ef01af64"
7DEPENDS = "python-native dpkg-native"
8
9SRC_URI = "http://ftp.de.debian.org/debian/pool/main/m/mklibs/${BPN}_${PV}.tar.gz \
10 file://ac_init_fix.patch\
11 file://fix_STT_GNU_IFUNC.patch\
12"
13
14SRC_URI[md5sum] = "e597b01548204874feef396403615d9f"
15SRC_URI[sha256sum] = "e7fe79db2673bb26c98c63fd8b40dcb44b9b94c4bc52a8c4c8112a5cbaf29bf4"
16
17inherit autotools gettext native pythonnative
18
19do_configure_prepend() {
20 sed "s+MKLIBS_VERSION+${PV}+" ${S}/configure.ac
21}