summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm/llvm_git.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-03-30 19:50:04 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-31 23:30:36 +0100
commitef12246e320ab97da538253c95c5c509c979bbf0 (patch)
tree5d814de12a10cf29417495ae734f3491b395fcf6 /meta/recipes-devtools/llvm/llvm_git.bb
parent0907793d5e35b418e298e3cb739de85b0db1d24e (diff)
downloadpoky-ef12246e320ab97da538253c95c5c509c979bbf0.tar.gz
llvm: remove redundant CMake variables
This recipe uses the cmake class, so there's no need to set the Ninja backend, or tell it where Python is, or that we're cross-compiling. (From OE-Core rev: 2560665cc1e30a6ca969118ade8612393e1eef74) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/llvm/llvm_git.bb')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index f133653903..f617b17231 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -82,9 +82,8 @@ EXTRA_OECMAKE += "-DLLVM_ENABLE_ASSERTIONS=OFF \
82 -DLLVM_OPTIMIZED_TABLEGEN=ON \ 82 -DLLVM_OPTIMIZED_TABLEGEN=ON \
83 -DLLVM_TARGETS_TO_BUILD='${LLVM_TARGETS}' \ 83 -DLLVM_TARGETS_TO_BUILD='${LLVM_TARGETS}' \
84 -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON \ 84 -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON \
85 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \
86 -DCMAKE_BUILD_TYPE=Release \ 85 -DCMAKE_BUILD_TYPE=Release \
87 -G Ninja" 86 "
88 87
89EXTRA_OECMAKE:append:class-target = "\ 88EXTRA_OECMAKE:append:class-target = "\
90 -DCMAKE_CROSSCOMPILING:BOOL=ON \ 89 -DCMAKE_CROSSCOMPILING:BOOL=ON \