summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm/llvm_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-09-25 20:09:40 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-09-27 11:50:34 +0100
commit77d5805fd46e146d52096cd5073310aa19335829 (patch)
tree1d4219056b5928bd85493c82f9fe64b223362d78 /meta/recipes-devtools/llvm/llvm_git.bb
parent07bf0ce327f2f237dcdea51d0a4506955089b722 (diff)
downloadpoky-77d5805fd46e146d52096cd5073310aa19335829.tar.gz
llvm: Upgrade to 17.0.2
* 481358974fb0 [GVN] Also remove phi nodes from VN table (PR65447) * 9f77e96186be [GVN] Invalidate MDA when deduplicating phi nodes * a13a89402f53 Bump version to 17.0.2 * 2c04bdb24677 [SVE] Ensure SVE call operands passed via memory are correctly initialised. (#66070) * 701620d58cdf [SVE] Precommit test to show missing initialisation of call operand. (From OE-Core rev: c2e059a036ac5c4d2cb3c7267be2403e0611dea5) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/llvm/llvm_git.bb')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 611aacba14..934f842b90 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -14,14 +14,14 @@ RDEPENDS:${PN}:append:class-target = " ncurses-terminfo"
14 14
15inherit cmake pkgconfig 15inherit cmake pkgconfig
16 16
17PV = "17.0.1" 17PV = "17.0.2"
18 18
19MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}" 19MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}"
20 20
21LLVM_RELEASE = "${PV}" 21LLVM_RELEASE = "${PV}"
22 22
23BRANCH = "release/${MAJOR_VERSION}.x" 23BRANCH = "release/${MAJOR_VERSION}.x"
24SRCREV = "e19b7dc36bc047b9eb72078d034596be766da350" 24SRCREV = "481358974fb0f732e33d503c224492a543f4d7bd"
25SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \ 25SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH};protocol=https \
26 file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \ 26 file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
27 file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \ 27 file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \