summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm/llvm_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-04-20 09:33:54 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-04 13:28:05 +0100
commit51394baea4109ad130e0806848773734db0ca49f (patch)
treee7c7d4d1955154e091252bcbeb93f3c8cd7fb13a /meta/recipes-devtools/llvm/llvm_git.bb
parenta68dd429c2d582bf67a00450ac0e8736eac744fe (diff)
downloadpoky-51394baea4109ad130e0806848773734db0ca49f.tar.gz
llvm: Fix [compile-host-path] QA issue
Its trying to build NATIVE llvm-config which is already built with llvm-native so we do not need to rebuild it Drop setting NINJA_STATUS explicitly, its no longer needed, on the contrary it hinders the task status update (From OE-Core rev: f8393b2b4bc5fbd972be00cb17d0c574ae8deff9) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/llvm/llvm_git.bb')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 77c095d9a3..cb3bba6fab 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -26,6 +26,7 @@ PATCH_VERSION = "0"
26SRC_URI = "git://github.com/llvm-mirror/llvm.git;branch=${BRANCH};protocol=http \ 26SRC_URI = "git://github.com/llvm-mirror/llvm.git;branch=${BRANCH};protocol=http \
27 file://0001-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch \ 27 file://0001-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch \
28 file://0002-llvm-allow-env-override-of-exe-path.patch \ 28 file://0002-llvm-allow-env-override-of-exe-path.patch \
29 file://0001-Disable-generating-a-native-llvm-config.patch \
29 " 30 "
30UPSTREAM_CHECK_COMMITS = "1" 31UPSTREAM_CHECK_COMMITS = "1"
31S = "${WORKDIR}/git" 32S = "${WORKDIR}/git"
@@ -85,15 +86,15 @@ do_configure_prepend() {
85} 86}
86 87
87do_compile() { 88do_compile() {
88 NINJA_STATUS="[%p] " ninja -v ${PARALLEL_MAKE} 89 ninja -v ${PARALLEL_MAKE}
89} 90}
90 91
91do_compile_class-native() { 92do_compile_class-native() {
92 NINJA_STATUS="[%p] " ninja -v ${PARALLEL_MAKE} llvm-config llvm-tblgen 93 ninja -v ${PARALLEL_MAKE} llvm-config llvm-tblgen
93} 94}
94 95
95do_install() { 96do_install() {
96 NINJA_STATUS="[%p] " DESTDIR=${LLVM_INSTALL_DIR} ninja -v install 97 DESTDIR=${LLVM_INSTALL_DIR} ninja -v install
97 install -D -m 0755 ${B}/bin/llvm-config ${D}${libdir}/${LLVM_DIR}/llvm-config 98 install -D -m 0755 ${B}/bin/llvm-config ${D}${libdir}/${LLVM_DIR}/llvm-config
98 99
99 install -d ${D}${bindir}/${LLVM_DIR} 100 install -d ${D}${bindir}/${LLVM_DIR}