summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm/llvm_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-02-26 23:41:30 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-01 11:12:16 +0000
commit42c9988492254722846a986a436a6ae17af5e199 (patch)
tree5b453fa83f916b1871780e7eb677c493798b90d5 /meta/recipes-devtools/llvm/llvm_git.bb
parentc5992b47e81c9931a0e6ab376b8f06d667241fec (diff)
downloadpoky-42c9988492254722846a986a436a6ae17af5e199.tar.gz
llvm: Fix build with c++17
Fixes /benchmark_register.h:17:30: error: 'numeric_limits' is not a member of 'std' | static const T kmax = std::numeric_limits<T>::max(); | ^~~~~~~~~~~~~~ (From OE-Core rev: e093eff9d94c02939ca398d59d66d1b1dbc8a12e) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/llvm/llvm_git.bb')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 86def0878c..db6694339c 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -34,6 +34,7 @@ SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH} \
34 file://0006-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch;striplevel=2 \ 34 file://0006-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch;striplevel=2 \
35 file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \ 35 file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
36 file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \ 36 file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \
37 file://0001-nfc-Fix-missing-include.patch;striplevel=2 \
37 " 38 "
38 39
39UPSTREAM_CHECK_GITTAGREGEX = "llvmorg-(?P<pver>\d+(\.\d+)+)" 40UPSTREAM_CHECK_GITTAGREGEX = "llvmorg-(?P<pver>\d+(\.\d+)+)"