summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool_2.4.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-11-08 11:10:56 -0800
committerSaul Wold <Saul.Wold@intel.com>2010-11-18 13:30:25 -0800
commit563953df47785bf57969d86b9b5f8494e585a28c (patch)
tree4b9d4cdb858f08894503dcd5233e6bcf5ed7ab6e /meta/recipes-devtools/libtool/libtool_2.4.bb
parentaa5befab23679e07441805e18d9b6f3f271b5ed5 (diff)
downloadpoky-563953df47785bf57969d86b9b5f8494e585a28c.tar.gz
libtool upgrade from 2.2.10 to 2.4
Taking out of this code from patch as the newer upstream code has fix, and this patch is not needed. cross-compile.patch: -Index: libtool-2.2.10/libltdl/config/ltmain.m4sh +Index: libtool-2.4/libltdl/config/ltmain.m4sh =================================================================== ---- libtool-2.2.10.orig/libltdl/config/ltmain.m4sh -+++ libtool-2.2.10/libltdl/config/ltmain.m4sh -@@ -5147,8 +5147,14 @@ func_mode_link () - absdir="$abs_ladir" - libdir="$abs_ladir" - else -- dir="$libdir" -- absdir="$libdir" -+ # Adding 'libdir' from the .la file to our library search paths -+ # breaks crosscompilation horribly. We cheat here and don't add -+ # it, instead adding the path where we found the .la. -CL -+ dir="$abs_ladir" -+ absdir="$abs_ladir" -+ libdir="$abs_ladir" -+ #dir="$libdir" -+ #absdir="$libdir" - fi - test "X$hardcode_automatic" = Xyes && avoidtemprpath=yes - else Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool_2.4.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool_2.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool_2.4.bb b/meta/recipes-devtools/libtool/libtool_2.4.bb
new file mode 100644
index 0000000000..cca3b1ea4a
--- /dev/null
+++ b/meta/recipes-devtools/libtool/libtool_2.4.bb
@@ -0,0 +1,33 @@
1require libtool.inc
2DEPENDS = "libtool-native"
3
4PR = "r0"
5
6PACKAGES =+ "libltdl libltdl-dev libltdl-dbg"
7FILES_${PN} += "${datadir}/aclocal*"
8FILES_libltdl = "${libdir}/libltdl.so.*"
9FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h"
10FILES_libltdl-dbg = "${libdir}/.debug/"
11
12inherit autotools
13
14EXTRA_AUTORECONF = "--exclude=libtoolize"
15
16do_compile_prepend () {
17 # Sometimes this file doesn't get rebuilt, force the issue
18 rm -f ${S}/libltdl/config/ltmain.sh
19 make libltdl/config/ltmain.sh
20}
21
22#
23# We want the results of libtool-cross preserved - don't stage anything ourselves.
24#
25SYSROOT_PREPROCESS_FUNCS += "libtool_sysroot_preprocess"
26
27libtool_sysroot_preprocess () {
28 if [ "${PN}" == "libtool" ]; then
29 rm -rf ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${bindir}/*
30 rm -rf ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${datadir}/aclocal/*
31 rm -rf ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${datadir}/libtool/config/*
32 fi
33}